Can't change the Raspicam orientation or resolution with the current version of octoprint

I have a new OctoPrint setup (1.8.6) running on a RPi 3A+, connected to an Ender 5 Plus and to a genuine Raspberry V2 noir cam, connected via the ribbon cable. The RPi is not running anything else. I might connect IR LEDs in the future but that's about it.

Printing works flawlessly, also time-lapse recording. My issue is that the cam is mounted upside down and only providing a 480p feed. I managed to invert the image in the UI settings, so at least my timelapses are the right orientation, but they are still low quality.

Ideally I would like two things:

  1. high res timelapses
  2. also a higher res and properly orientated stream via IP/webcam/?action=stream for monitoring purposes.

I assumed that therefore setting the resolution and orientation somewhere deeper than the UI in the system configuration would be ideal. After 5-6h of googling and only errors I am now so frustrated I thought I would ask for help.

I have tried all sorts of commands editing the octopi.txt via SSH, some include:

camera_usb_options="-r 640x480 -f 10 -y"
camera_usb_options="-r 1920x1080 -f 30"

camera_raspi_options="-r 1280x720 -f 20 -hf -vf"
camera_raspi_options="-x 1280 -y 720 -fps 20 -hf -vf -y"

And all sorts of combinations and variations of framerates and resolutions.

Regardless of what I do I either get the standard inverted 480p stream or an error message saying there is no webcam stream.

I have also looked at followed the following threads:

None of these have helped.

Where and how do I set the camera up correctly with the current release of octoprint? What resolution should I go for?

Thanks in advance!!! (366.1 KB)

I too have this issue. My 4B was working flawlessly with the previous OctoPi version. After upgrading to 1.0.0, I've finally figured out that the raspicam works out of the box, but I can't change the resolution.

640x480 shows a stream, but trying to change to the native 1640x1232 doesn't work.

camera_usb_options="-r 1640x1232"

Same issue too.
My pi cam was working with the previous Octopi version.
I tried this too :OctoPrint-CameraSettings/ at a7e444f5f827c32e62e05a52a15c0745474693ca · The-EG/OctoPrint-CameraSettings · GitHub

But nothing worked.