Can't connect to octopi.local using wifi on Windows Laptop

What is the problem?
I was using Octopi happily for a long time. I left my printer off for a week and came back and it seemed to have lost the connection to wifi using octopi.local. I can connect fine to the IP address for my Raspberry Pi using an Ethernet connection and as long as it is hard wired, it works fine with Cura and I can print, etc. I can even see the camera and monitor temps, etc. However when I disconnect the Pi from Ethernet and try to connect from my Windows Laptop, I cannot connect using octopi.local at all and when I try to connect using the static IP address, it seems to connect but I only get a Text version of the Octoprint UI (see attached) and I cannot print. I CAN, however, connect to octopi.local just fine from my iphone or other device. Seems like something simple on my Windows laptop but not sure what it is.

What did you already try to solve it?
I followed a number of the steps on this site (WiFi setup and troubleshooting) including trying different references to my network on the octopi-wpa-supplicant.txt file and also tried updating the octopi-network.txt instead. I don't think the problem is there since my Pi seems to be connected fine... it is just getting to it from my laptop which seems to be the issue. I also updated the hosts file on my laptop to point to the IP address when referencing octopi.local but that did nothing.

Logs (syslog, dmesg, ... no logs, no support)
Let me know what logs will be helpful in this case and where I can find them.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I'm running netgear router and Cura is intalled on a Windows 10 laptop. Not sure what else to provide.

Thank you!

I am having a similar problem. Octoremote works on my phone. I can ping the IP address and it works fine. I used tracert and the URL that it returned was different. The Octoprint login comes up but after entering the credentials the browser just seems to stall out.

I am guessing it has something to do with an update... but not sure how to track this down.

I have had some luck with my problem. I was able to connect using the Edge browser, and then was able to disable the TouchUI plugin. This helped on the Edge Browser, but was not helpful on accessing Octoprint with Chrome which is my preferred browser. At this point I am able to print though which is acceptable.

I fixed by loading a new Octoprint SD card in my Pi. I’m frustrated that I’m not sure why the issue was happening but was happy to have it back up…. Had it working fine, Len left the printer off again fir a week, brought it back up and now I can get everything to load in the browser using octopi.local…. AND can see the printer webcam…. But, now I can’t get Octoprint to connect to my printer. Ugh! This is very temperamental. I looked through the logs while ssh’d into the Pi and saw low voltage alert so I replaced the power cable…. No more low voltage alert but still can’t connect to the printer. Now what.

Your router may have changed the IP address. I was having similar issues after not using the system for a couple weeks. I found my router assigned a new IP it changed from 190 to 188. I think adding new Wyze cams during the off time may have used the 190 address.
I started using the IP on connect (OctoPrint-ipOnConnect) plugin to show the IP address on the Ender 3 display screen to help connections. I don't connect using OCTOPI.LOCAL, I instead just toss the IP address into the search block. This helps me get to the proper machine because I have two separate OctoPi setups.
I'm not tech savvy enough to figure out how to assign devices specific addresses in my router. IP-on-Connect has enabled me to not worry about it. There is an app for cellphones called FING, it analyzes your WiFi at home and tells you everything attached to your router with IP addresses and generic naming.

1 Like

As far as I am aware Mickeysoft does not have mDNS, or if it does its not as reliable as mac/ linux implementations..

using the pi IP address instead of the .local is a more reliable way to connect I have found

Have you entered the correct baud rate etc in the printer connection settings? sometimes auto fails..

So this is no longer a network issue.

Please share the logs. Also try this:

And if yo have a Creality printer try with and without the SD card in the printers slot.

Thank you.
This had happened to me. Downloaded FING, found the IP address, tapped it into the browser and everything is working again.

1 Like