Can't get Octoprint to connect to Printer

What is the problem?

Cant get Octoprint to discover printer

What did you already try to solve it?

Using a raspberry pi zero 2W, seems to be working right and I can open up octoprint, but it wont recognize printer. Tried an OTG connector and a USB connector as well off of a USB bank.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

no (74.6 KB)
added log

Hello @Cody_Heller !

What printer do you want to connect to?

Ender 6, have it wired off the PCU with a buck converter

Creality printers can be a bit picky when it comes to the USB connection.

You may try wit/without the SD card in the printer SD card slot.

Also you may try this:

Also, check the USB cable. There are some cables existing just for charging, without data wires and can't be distinguished from the full populated cables.

Im trying it with printer SD card out now and an OTG cable with the usb bank not attached to the raspberry pi, just trying to see if I can get it to recognize. Still nothing. Give me State: Offline after error every time I try to connect still

not sure if anyone else has any ideas

figured it out, data cord combined with using the wrong micro usb port to power the PI.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.