Cant Run Desktop Environment on Pi4 running test build

Hello! I am a total newbie to Octoprint.

Raspberry Pi 4 up and running using the Nightly build img.

Functionality is working perfectly, great prints, I cant get the desktop environment to load. Is this due to that functionality not being present for the current build?

Thanks and sorry if I'm ignorant to this.

Yeah the desktop is not included because the image is based on raspbian lite.
This should help you :wink:

Thanks so much for trying to help me.
So when you say "open" network, you mean an unsecured network? ie no password?

That part was part of the answer to the other thread.
Your pi just needs internet access. It doesn't matter how :slight_smile:

My Pi has internet access. I have a secured network but it the credentials are correctly configured and before I flashed octoprint, I could easily access google or the web chromium through raspian. When I run the script to install the desktop environment, a good portion runs ok, but there are some files that show unreachable.

Am I misunderstanding something? I apologize for any ignorance.

It would help to see which errors you're getting.
Could you copy the console output and post it here?

I can certainly try. Ill be home this evening and Ill try that.

So I flashed the nightly build for the Pi 4.
then it prompts with the script to install the desktop environment.
I run the script, some of it processes, and some doesnt, then it says its finished and asks if id like it setup so that it boots to desktop environment to which I answer yes. But it never does. Ive tried selecting it in config as well.

it also will not run sudo apt-get update

If you have a PiHole (or similar) configured, this can get in the way of some of the pip install ... sort of things trying to go on.

Im so new i have no idea what a PiHole is lol.

What happens if you just run apt-update?

It gives me an error saying that it cant

It fails to complete

Could you please copy the error and post it here?
Or make a screenshot of it?

I sure will. When I get home this evening. Thanks so much for working with me. Ill get that error posted later today

1 Like

Rule of thumb: "it gives an error" is never enough information to help. Always copy down the error and any lines preceding it precisely and provide it when seeking help with something. That doesn't only apply to OctoPrint, it's a good idea in general. Error messages are supposed to help to figure out what went wrong. They can't serve that purpose if they are kept secret :wink:

1 Like

Will do. Thanks foosel.

Here are some screenshots of the Pi output when trying to install the desktop environment

Does the same happen if you first run sudo apt update before running sudo /home/pi/scripts/install-desktop?

I have also been unsuccessful running the apt update script. I still need to get copies of that output for you on that.

I am not sure this is the case, but I have had problems with IPv6 to complete install packages or updates for raspbian. It says the same, it was unable to get some files. This is not a problem from the side of the raspberry pi. The router gave the raspberry pi IPv4 and IPv6 address, and so, it tries to reach some sites (software mirrors) on IPv6 when possible. I haven't pinpoint where the IPv6 resolution fails, but the end result is that some mirrors are unreachable and some of them just hang without for response stalling the installation of sofware. I may guess is a problem with settings on the internet service provider, like there is no good routing for IPv6. I can't change setting on the router to avoid assigning IPv6 to the devices at home.
Mi solution is to disable IPv6 for the raspberry pi, and then it works fine when trying to install packages or update. I have follow this guide: tech republic - how to disable ipv6
I hope this helps.