🇺🇦 We stand with Ukraine! 🇺🇦

Can't upgrade to V 1.6.1

What is the problem?

Can't update to 1.6.1 from 1.4.0 Have tried to send serial log, and other one requested but shows sent, but get email later in day the email was not deliverable. Is there a chance that I can upgrade to 1.6.0 first, then 1.6.1? Can't find out where to get 1.6.0 to try. Can't send you the bundle info because you have to have at least 1.6.0

What did you already try to solve it?

Repeatedly try to upgrade from with in Octoprint

Have you tried running in safe mode?

Don't know how

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Can't get system info bundle unless you have version 1.6.0

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint V1.4.0, Octopi 3B+ (not sure what version) haven't updated since installed about year and a half ago-never been updated by me. Printer is Prusa MK3s, printer firmware 3.8, browser Google Chrome, Window 10 OS

Then please share the octoprint.log

octoprint (4).log (1.3 MB)

  1. Please disable the debugging. It floods the log with messages, that are not needed.
  2. Please do not reset the Pi by pulling the plug. Sooner or later you will end with a corrupted filesystem on the SD card.
  3. It seems the Pi has no connection to the internet:
2021-06-03 03:17:08,794 - octoprint.startup - INFO - We don't appear to be online, not fetching plugin blacklist

Under logging levels, I changed to info. I don't reset PI by pulling the plug. It's on until I am done printing for the day, then I turn off the printer first, then power down the PI. The PI has connection to the internet because that is how I transfer files to Octoprint, then to printer.

Anyhow, this is not a regular shutdown via the system menu of the pi:

2021-06-03 00:06:26,460 - octoprint.plugins.tracking - INFO - Sent tracking event ping, payload: {'octoprint_uptime': 43223}
2021-06-03 00:17:08,546 - octoprint.startup - INFO - ******************************************************************************
2021-06-03 00:17:08,548 - octoprint.startup - INFO - Starting OctoPrint 1.4.0
2021-06-03 00:17:08,549 - octoprint.startup - INFO - ******************************************************************************

Can you please share this log: plugin_softwareupdate_console.log

So should I shut down Octoprint first then octopi? Here is that log.
plugin_softwareupdate_console (1).log (162.1 KB)

It shuts down the complete system on the Pi.

From the log:
The 1.6.1 files are actually downloaded, but can't actually not be installed due to an exception error.
I'm bit helpless at that point, maybe moneone else can help here.

Take a look at Updating OctoPi / not a directory - #8 by foosel

I cannot update from 1.4 to 1.6.1 either. Here's what seems to be the pertinent section of the error:
Installing build dependencies: startedInstalling build dependencies: finished with status 'error'ERROR: Command errored out with exit status 1:command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-YJAEds/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i Simple index --extra-index-url piwheels - Simple index -- setuptools wheel Cythoncwd: NoneComplete output (24 lines):Traceback (most recent call last):File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main"main", fname, loader, pkg_name)File "/usr/lib/python2.7/runpy.py", line 72, in _run_codeexec code in run_globalsFile "/home/pi/oprint/lib/python2.7/site-packages/pip/main.py", line 16, in from pip._internal.main import main as _main # isort:skip # noqaFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/main.py", line 13, in from pip._internal.cli.autocompletion import autocompleteFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/autocompletion.py", line 11, in from pip._internal.cli.main_parser import create_main_parserFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/main_parser.py", line 7, in from pip._internal.cli import cmdoptionsFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/cmdoptions.py", line 25, in from pip._internal.locations import USER_CACHE_DIR, get_src_prefixFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/locations.py", line 18, in from pip._internal.utils import appdirsFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/utils/appdirs.py", line 16, in from pip._internal.utils.compat import WINDOWS, expanduserFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/utils/compat.py", line 17, in from pip._vendor.urllib3.util import IS_PYOPENSSLFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_vendor/urllib3/init.py", line 21, in from logging import NullHandlerImportError: cannot import name NullHandler----------------------------------------ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-YJAEds/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i Simple index --extra-index-url piwheels - Simple index -- setuptools wheel Cython Check the logs for full command output

octoprint.log (38.7 KB)

See:

That will almost certainly get you on your way with the update.

You're also using Python 2.7, which while it still works is deprecated and will no longer be supported soon. See below for more.

1 Like

Fantastic help, thank you. I tried to uninstall logging but PuTTy interface said, "-bash: /home/pi/octoprint/bin/pip: No such file or directory"

Read carefully - it should be /home/pi/oprint/bin/pip. oprint not octoprint.