Communication Error Ender 5 Plus

What is the problem?

Communication Error when connecting to printer. It will make a connection sometimes, but most of the time in order to get it to make first connection ill have to turn the printer and the pi off and then turn back on. It will make a connection, then within 15-30 seconds max will disconnect and say "Communication Error". I have not been able to have it maintain a connection for longer than that.

I'm beginning to wonder if maybe its the board? I'm at a loss and have been working on this for several days.

What did you already try to solve it?

I've tried over 5 different USB cords.
I cut the red wire in one of the cords.
I taped the 5v with electrical tape.
I ordered a brand new cord. It made no improvements.
I installed octoprint on my laptop to make sure it wasn't the Pi, and it did not work with the laptop either.
I've tried increasing the Timeouts.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 915718144
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.2
systeminfo.generator: zipapi

Additional information about your setup

I am using the Creality Ender 5 Plus Silent Motherboard V2.2 with TMC2208 I purchased from Amazon. I upgraded the firmware to Ender 5 Plus BL Touch 0904 v.1.71.0 KF from Kersey Fabrications. I've had no other issues aside from not being able to connect to Octoprint.

Below is the log.

2021-12-17 14:53:23,640 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Opening serial connection"
2021-12-17 14:53:23,642 - octoprint.util.comm - INFO - Connecting to port /dev/ttyUSB0, baudrate 115200
2021-12-17 14:53:23,668 - octoprint.util.comm - INFO - Changing monitoring state from "Opening serial connection" to "Connecting"
2021-12-17 14:53:23,679 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2021-12-17 14:53:24,634 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2021-12-17 14:53:26,782 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2021-12-17 14:53:26,789 - octoprint.util.comm - INFO - Changing monitoring state from "Connecting" to "Operational"
2021-12-17 14:53:26,887 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2021-12-17 14:53:27,030 - octoprint.util.comm - INFO - Printer reports firmware name "Marlin Ver 1.71.0 KF (Kersey Fabrications)"
2021-12-17 14:53:27,055 - octoprint.util.comm - INFO - Firmware states that it supports temperature autoreporting
2021-12-17 14:55:01,586 - octoprint.util.comm - INFO - No response from printer after 3 consecutive communication timeouts, considering it dead.
2021-12-17 14:55:01,610 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Offline after error"
2021-12-17 14:55:01,631 - octoprint.plugins.action_command_notification - INFO - Notifications cleared

Hello @DommTheDon !


Sorry about that, Here is the full bundle (64.2 KB)

For this is a Creality printer, you may try this:

Also you may try without the SD card in the printer.

Also, from time to time, you have an undervoltage issue:

2021-12-16 14:50:02,997 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

I tried all of those recommendations without any fixes. I appreciate the suggestions though. I've also tried swapping the power on the Pi and due to that is when I ran into some low voltage warnings, but then went back to power supplies/cords that did not give me that warning.

I even ordered the power blough that was recommended and it is on its way, although I don't think that will correct my current situation as the tape and cutting the red wire has not fixed it any.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.