Creality CR10 S Pro wont heat or start print

What is the problem?

Newly Installed Octoprint on Pi won't heat bed or print from uploaded g-code to CR10S Pro V2. Have printed from SD on this printer for over a year with no issue. Get the error: Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!

What did you already try to solve it?

rebooted and retried. took out the SD card and retried. tried a different file. Tried to update firmware with the firmware updater plugin but doesn't seem to work with my board.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Octoprint Version 1.8.6
Octopi Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.4, Creality CR 10S ProV2, Creality firmware (presumeably Marlin 1.1.6) Brave Browser, Windows 10 (61.3 KB)

Sorry I downloaded to System info bundle and forgot to attach (61.3 KB)

I assume the printer is powered on?
With some printers it can happen, that the LCD and the printers MCU are powered up by backpowering from the Pi's USB.

See more on this here:

and here:

Thank you so much! This community is so responsive and helpful. I hope I can contribute once I have learned more. For folks from the future who have the same issue as me, I had assumed that the fact that plugging the Pi into my CR 10S Pro V2 turned the machine on, that it functioned as a switch intermediary and turned on the power supply since I could see the LCD interface and heard it turn on. Not the case. First turn on your machine, then plug in the USB. I didn't have to do the tape trick, just turn on the machine, duh!

1 Like

you should do the 5v tape mod. Having the printer pulling 5v off the pi even with the printer turned on can lead to problems.

As I mentioned in my post :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.