Desktop interface changed

What is the problem?

After Edge update, my Octoprint doesn;t look like it used to and I cannot find a configuration to change. Trying attachment of what I wish desktop to look like.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


That isn't OctoPrint, that is its project homepage.

It looks like the first tab on the left, could be the OctoPrint UI?

I didn’t crop the screenshot, just wanted to show the config I want to get back to. It distinctly says Octoprint in upper left hand corner.

We know how OctoPrint should look.
But how does you OctoPrint looks right now?
That would help us more.

As others have said, we don't know what your OctoPrint interface looks right now, so sharing a screenshot of THAT would help us to help you get it can up what you expect it to look like. Please open a tab showing your OctoPrint UI, then make a screenshot of that and upload it. Also share a system info bundle and try safe mode.

Sharing the screenshot on the project homepage tells us absolutely nothing, as already said we all know how it's supposed to look.

here is screenshot. Looks like a 1984 monochrome monitor. Tried safe mode, nothing changed. In the current mode, I cannot find a way to download system info bundle - in the link you included, it refers to a tab in the interface I am trying to restore. Thx beforehand.

When you go to the menu icon on the right top, there should be a menu point to switch off TouchUI:


1 Like

The UI you are seeing, as already mentioned by @Ewald_Ikemann, comes from the third party plugin TouchUI that you installed. Starting in safe mode should have disabled that. The only reason I can see why it didn't help is that your browser still had the changes applied by TouchUI cached somehow (it's frontend styling only).

Regarding the systeminfo bundle, the link describes 4 ways to retrieve one, only two of which are located in the regular UI. One is via the recovery page:

It's part of the recovery page that you can access by appending /recovery to your OctoPrint URL, e.g. http://octopi.local/recovery (you need Admin permissions for this).

In any case, the steps by Ewald should get you sorted.

OK. That's it. A big thank you.

FYI, since you aren't the first one running into this problem, I've just added an FAQ entry that will hopefully help others in the future: