Ender 2 Pro won't connect to Octoprint

What is the problem?

Flashed a copy of octoprint to a Pi Zero 2. Have everything connected. Octoprint connects to the wifi and I can load the home page however it does not recognize any printer connected.

What did you already try to solve it?
Swapped wires, restarted multiple times, removed sd card. SSH'd into the PI via putty as per troubleshooting instructions. Get message saying new USB device found but no drive claiming it as far as I can tell.

Anyone know what's going on? I see other people with Ender 2 Pros using OctoPi. I thought I read somewhere that some motherboards for the ender 2 pro are not compatible, can anyone confirm? Thanks in advance!

System Info Bundle
octoprint-systeminfo-20230216151806.zip (20.8 KB)

Have you tried running in safe mode?

Did running in safe mode solve the problem?

And what's about the systeminfo bundle?

Also try wit/without the SD card in the printer's SD card slot.

Other USB cables (more than two others :wink: )


Are you using the correct USB port?
The left one (the inner one) is for USB connections and the right one is for power.

Yes, that is plugged in correctly.

Alrighty then (as @Ewald_Ikemann already said) we need the Systeminfo Bundle.

Also we should check if the pi detects the printer at all.

Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

Tried a couple cables from the pi to the printer. Haven't tried new power cords, but will do that. Updated the system info bundle in the description, thanks! I will also give the tape a shot.

octoprint-systeminfo-20230216151806.zip (20.8 KB)

Thanks! Here it is:

pi@octopi:~ $ dmesg | tail -n 20
[ 10.594819] random: crng init done
[ 10.594847] random: 7 urandom warning(s) missed due to ratelimiting
[ 10.664335] uart-pl011 3f201000.serial: no DMA platform data
[ 10.700971] 8021q: 802.1Q VLAN Support v1.8
[ 10.854902] Adding 102396k swap on /var/swap. Priority:-2 extents:22 across:149172k SSFS
[ 10.970353] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
[ 12.362882] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 16.331729] Bluetooth: Core ver 2.22
[ 16.331874] NET: Registered protocol family 31
[ 16.331888] Bluetooth: HCI device and connection manager initialized
[ 16.331922] Bluetooth: HCI socket layer initialized
[ 16.331943] Bluetooth: L2CAP socket layer initialized
[ 16.331977] Bluetooth: SCO socket layer initialized
[ 16.343931] Bluetooth: HCI UART driver ver 2.3
[ 16.343948] Bluetooth: HCI UART protocol H4 registered
[ 16.344031] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 16.344206] Bluetooth: HCI UART protocol Broadcom registered
[ 16.608952] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 16.608968] Bluetooth: BNEP filters: protocol multicast
[ 16.608988] Bluetooth: BNEP socket layer initialized

I realize the tape is for USB, not micro USB connection. Connecting to Pi Zero 2 via micro usb.

Anyone know what's going on?

The Pi doesn't detect the printer at all.
You can run sudo dmesg -w and try other cables and test if you get anything.

Thank you, I'll try some other cables.

I'm having the same issues. I just installed Octopi via the installer script. I try to connect but it does nothing. It sure would be nice if it informed me that it couldn't connect or there was an error, or simply acknowledged that I even hit a button. But it does nothing.

I've tried all the ports and auto etc. I am running Linux Mint 21 I tried lsusb and it lists the printer. I tried dmesg and it lists the printer too. However nothing I do gets a response from the UI.

I tried setting a profile for the printer. That gives me an error about connection. I checked the octoprint logs and it has something about ssl.
Anyone know WTF is going on?


This doesn't sound like the same issue. Normally OctoPrint will tell you even before you try and connect the printer there are no available ports, or if you do press connect you will see it try and then error. In the OP, there is no printer detected by the OS, but in your comment you say there is, so it's definitely not the same issue.

I would probably recommend opening a new topic, and testing in safe mode and providing said logs so that someone could look at them and maybe see what's wrong.

Thanks I finally got it working. I tried refreshing the tab, that didn't work. I tried restarting the browser, that didn't work. I finally restarted the computer, that worked.

Before I restarted the computer, hitting the connect button did nothing. Creating a profile wouldn't work either. Now it all seems to be working. I have no idea why I had to restart the computer.

I didn't want to start a new topic because this seemed like my issue. It is weird that restarting the entire machine fixed it. But apparently that will always be the magic trick with computers. "Have you tried restarting it" LMFAO :joy:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.