Ender-3 axis crashes when homeing though octoprint

What is the problem?

Ender-3 x axis crashes when homing though octoprint ignores stop switches and tries to exceed them, no issues when homing through the ender 3 directly.

What did you already try to solve it?

Ran in safe mode, taped the 5V pin on usb, changed axis cables, changed ender mother board, re-flashed fresh octopi image

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 914006016
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.6-20221018093204
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x50000
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.8.6
systeminfo.generated: 2022-12-22T09:54:18Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

First board was the 1.1.5 silent board, issue persist to the 4.2.7 board, both running Marlin with bltouch. I am running a raspberry pi 3 B+, with a 32gig sd card. I cut the printers power before it attempts the other axis no idea if the issue persist to the y and z axis.

Hello @Steelmonkey !

Do you have an SD card in the printer or not?

This seemed to have fixed it, I could not for the life of me find this solution. It's weird since I've used octo print for almost 4 years and this issue only started appearing no more then a month ago. Thank you so much.

You might have a failing end stop microswitch - the X axis on one of my Ender 3's did just that the other day, resulting in a Halt, Homing Failed, RESET printer message [Marlin 2.0.9.1 on a stock Ender3 mainboard].
You can get spare switches ready mounted on the PCB for next to nothing from Aliexpress if you can't find them anywhere else.. One of things I keep handy for when something breaks.

You might have seen the the OP already had a solution for the issue with post #3

I did, but I've got four different types of Creality printer and none have ever done that, they didn't stay on stock firmware for very long though... its one of those YMMV problems.