Ender 3 is drawing too much current. USB cable is getting quite warm

What is the problem?
After hours of normal operation on previous days, I fire up my Octopi and Ender 3 to print. 15 minutes into a 2 hour print, the connection to the Ender 3 via USB cable is lost. I reboot everything, and it won't reconnect. After some trouble shooting, I find that the USB cable is hot (read: warm). This says to me that the printer is drawing too much current. I googled around some, and found some posts saying a powered USB hub could remedy the issue. I just find it confusing because it's been working fine, and my power supply should be more than capable of supplying enough current. Nothing else is remotely warm (raspberry pi, buck-boost ps, etc.)

What did you already try to solve it?
I switched USB cables, and the same symptom. Checked the voltages on my buck-boost power supply. No issues there. My cables are 3 feet long. I've printed for probably 40 hours on the same set-up. Nothing has changed.

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
I'm at work right now, so I can't really check (I never put the OctoPrint server across my firewall).
My Ender 3 is running Marlin 1.8 with BL Touch.

Hi @Glenneff!

The printer is not fed by the USB cable - reads the printer does not draw current over the USB cable. It has it's own power supply. Also the the current is limited to 500 mA by the USB port.
When the USB cable gets warm, I assume a short circuit in the USB socket of the Pi so an amout of current comes from the printer board over the USB cable to the Pi and back again to the printer and it gets warm.
Have you tried another port on the Pi? Have you tried to connect the printer to the PC?

1 Like

Thank you for the reply!. I've tried it on all 4 ports with the same symptom. My OctoPi is controlling a relay that controls the power to the printer, so I had that enabled. I plugged the printer usb port directly into my computer's usb. Tried to print via USB from CURA, and the screen dimmed to where the characters were barely legible.

Unplug that printer from mains and anything else and get it checked immediately. That sounds utterly unhealthy and outright dangerous.


Sounds like you've got a short to ground which is running all available current through those wires. 1) Lose the relay which is the likeliest culprit. 2) review the jumpers on your printer board to verify that it's getting its power from its own adapter rather than via the USB Type-B connector or similar.


I should have mentioned that the usb cable did not get warm when plugged into the computer. I'll do as you suggested tonight and report back. Thanks everyone for the advice.

If you're sure nothing is wrong with the electrics of your printer you can try this
(But first check the other suggestions)

1 Like

Update: I removed my OctoPi from the system last night. When I plugged my power supply directly to the controller, to my horror, nothing came on. I removed the cover and looked and the 24V wires. Nothing looked wrong. Nothing smelled off. I wiggled them, the Ender 3 came to life for a moment then off again. I shut off the power supply, removed the controller board, took a peak underneath, and lo-and-behold, there was a very visible cold solder on the (-) input pin. Sorry for the poor picture quality. I soldered it back up and examined all the other soldering joints. There weren't any clear issues. I reassembled it, it came on normally. I made a test print. No issue as I mentioned in the OP. I didn't have time to dive into the OctoPi last night, but I'll get to that tonight. I have a theory as to what was going on.


If the printer board wasn't getting powered (correctly) itself then it's possible that the Pi was trying to back-power it through the USB serial line.

1 Like

That's exactly what I was thinking.

"I have a theory, but I didn't have time to test it last night. The power supply was feeding the OctoPi just fine. However, and I've done this before when my Ender 3 was factory, if I ever tried to print something when I've forgotten to turn on the power supply, the bed would actually heat up a small amount. I think the same was happening here. The cold solder broke somewhere in my initial print. Then when trying to print again, the printer was attempting to pull the current to heat the bed from the usb cable which is obviously too much for it. Thus, it was getting warm."

I'm don't think the few watts the pi delivers on the usb port are enough to heat up a cable.

I think this is not a matter how much current the pi delivers over usb.
In this case (if I undestand it right) - a broken GND connection between printer mainboard and the powersupply - all the current which flows normaly over this connection now flows over the next "reachable" GND-connection in this case the USB-cable ...


Oh ok I see :slight_smile:

Plus, many manufactures don't do current limiting by USB type for power. The microUSB is supposed to only allow like 2.1A of power and everyone suggests that the Pi3B needs 2.5A (it does) in order to run. That's why they've changed it to a USB type C connection for the 4B.

Further, they pay little attention to the size of the gauge of the internal USB wiring to allow more current. So the printer board sinked all kinds of power from the Pi, literally nothing stopped it from doing so (other than the rating of the Pi's power adapter) and the tiny wires heated up.


Thanks for all the help everyone. I went through last night, checked everything, and made sure it was as it should be. I re-integrated the OctoPi, made a long test print, and the problem was resolved. Now if I can just get this PETG to print properly. Cheers.