Ender 3 V2 Connection Issue

What is the problem?
Not new to 3D printing, although this is the first 3D printer that I have bought for myself and set up. (I had only used the ones at work before) I have not printed anything as of yet, because I first wanted to get my whole setup ready. I built an enclosure for it, ordered filament, ect. In preperation. I got down to the last step-octoprint, and that's where everything went downhill. The octopi software booted right up and I was able to connect to it by http://octopi.local and set everything up, but for some reason I can not connect to my printer. I know that this issue has happened before, believe me, I have scoured the internet before resorting to posting here. The answer is always the same. "Replace the USB cable" I have done so with about 10 usb cables by now and none of them work. I did however find a usb cable with a tag on it though, and was able to look up the part number to find that it is in fact both charging and data. I also know it is data because when I use the same cable, I can connect to cura on my Windows 11 pc just fine, and can control the printer. I really do not know what to do, I know that my raspberry pi works, because I have used it for projects in the past.
What did you already try to solve it?

  1. Swap USB cables
  2. Followed steps in the FAQ like "wait for start on connect", ect.
  3. Re-flash the octopi image

Logs (syslog, dmesg, ... no logs, no support)
octoprint.log (29.2 KB)
octoprint-systeminfo-20230305224502.zip (13.4 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I tried using both a 4G and a 5G network, neither changed any connectivity's to the printer, so I really don't think it's a network issue, but this was the closest sub-forum I could think to put it in. Mods, feel free to move it though.

Please let me know if there is any other information I need to provide!

Hello @Noah_Torchick !

For you are using a Creality printer, try these:

With or without the SD card in the printer's SD card slot.

BTW: Connecting the Pi to the printer is not a networking issue.

I was hitting the same brick wall with my new Creality CR-X Pro after Christmas,
but had the variable of intermittent success.

First step was taping the 5V pin; bit of a flake process, as the tape can get pushed back.
Ended up grabbing the Dremel & grinding out the 5V pin at the USB-A end.
A lot tidier that splitting the cable to cut the 5V wire & taping it up.

2nd thing was removing the SD card from the printer.
Looking in the Terminal listing I could see that occasionally there was less that a full directory listing & in those instances things went wrong from there.

Don't know if it helped, but as well as leaving the card out I have also disabled SD card support in the feature.

Simply don't need it as I now upload all straight to the Pi.

I was very hopeful that this would work, after both you and @Phil23 said the same thing. As soon as I got home today, I tried it a few times, and it still does not work. I followed the guide that you linked to and taped the far right pin on the connector, but it still failed to work. Do either of you have any other Ideas?

Well... I am very sad to report... I guess the USB port on my raspberry pi gave out. I tried using a friend's raspberry pi and it booted right up. I really don't want to buy another one but I guess that Is the fix :frowning: Thank you guys for the help! You at least pointed me in the right direction.

Don't know if there's any relevance in this, but I did make a point of NOT using the USB 3.0 ports.

Just falls back to the occasional issues I've struck over the past 30 years,
(& USB hasn't been about that long yet), where port compatibility was an issue.

Saw it most around the times each new standard emerged.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.