Ender 3V2 grinding noise, not connecting, try to home and it kill codes

What is the problem?

I am very new to octoprint but I have had nothing but issues. I have imaged the pi all correctly and set all of that up.
So whats happening is when i first log in alls fine, it will connect all good. Then I will ask the printer to home, it tries to, motor moves etc. then i get a massive grinding noise, octoprint kills the action and disconnects from printer and will not connect again no matter what. Now I know the bed level issue on ender 3 v2 and the grinding noise is a thing, fixed that and does not do it when not plugged into the pi so i have no idea why it is making such a horrendous noise.

Please if you have suggestions be newbie friendly with step by step to how to fix things. I have spent a lot of time learning so much random stuff I dont really understand to apply some of the fixes I have tried.

What did you already try to solve it?

Now these are the fixes I have tried:
I have checked that I have a data cable, 8 cables later I bought a new one definitely not the issue.
The power supply is good so that is not my issue.
Tried in safe mode, did not fix anything.
The printer dimensions for the bed are all correct 220, 220 by 250.
The home is set to bottom left.
I have literally no idea, I have even opened up the pi config in putty to try and remove ttyAMA0 ( a fix i found here which didn't have any affect as it couldn't find the attribute anyway)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20210902181642.zip (53.5 KB)
browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36 Edg/92.0.902.84
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8204619776
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

octoprint.log (586.9 KB)

Additional information about your setup

Printer: ender 3 V2
Firmware: marlin V 1.0.4
Raspi: 4B
Octoprint Version: 1.6.1
Browser: tried both microsoft edge and chrome


homing is one command from octoprint to printer: "G28" if something goes wrong there it's usually a printer hardware/software issue.
Is there anything interesting in serial log?

see also your bundle:
2021-09-02 17:50:41,302 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

Have you tried taping the 5V pin on the cable? It may also help to use different firmware on the printer, the one that comes from Creality is widely known to have lots of issues.

Hi there, I have now enabled the serial log, how can I download the logs? Do i have to get it running again and try to home it and download the bundle again? Sorry very new not really a techy but trying to learn as much as I can

Hi @Charlie_Powell, thanks for the response, I have been reading about this a bit, is there a different firmware that you would recommend?
With the 5V pin, which cable are we talking about? I don't have any electrical tape at the moment so will have to source some before trying that out.

EDIT: I have done some research, and will order some electrical tape to try this out, I am assuming we are talking about the usb-A to micro cable :slight_smile:

octoprint.log (586.9 KB)
I have found the logs, read the forum post on it. I hope this is the one i need to upload

You may have found it already, but sorry, should have linked to this post:

1 Like

octoprint.log is already included in the support bundle. serial log needs to be enabled first, then you'll find it log location.

Wrt to the tape, a "normal" tape will do as well, it's not like we are talking high voltage here. (although it might be trickier to apply and remove)

Thank you for all the help, the 5V pin seemed to be causing so much trouble, I have finally done my first successful octoprint print with no connection issue and even ended up with an okay octolapse (although such a short print like a 5 second video hah!

1 Like

Thankyou for the help its appreciated, turned out to be the 5V pin!!