Ender3Pro + RPi 3b+ model drives me crazy

What is the problem?

Rpi 3b+ usb ports not working?

What did you already try to solve it?

Flashing octopi on many different sd cards, tried new power adapters, cables, every of them are working but not with the rpi

Have you tried running in safe mode and if so did it solve the issue?

Yes i have tried and no it didnt help

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

lsusb Bus 001 Device 004: ID 0424:7800 Standard Microsystems Corp. Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub lsusb -t

/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/3p, 480M
|__ Port 1: Dev 4, If 0, Class=Vendor Specific Class, Driver=lan78xx
serial.log (50 Bytes) octoprint.log (37.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


OctoPrint version : 1.4.2
OctoPi version : 0.17.0
Ender3Pro, stock-marlin?, google chrome, win10

So hello everyone, im a total noob at the raspberry business and with programming but i have saw many videos that its easy to set it up so i wanted to try it... I have bought a rpi 3b+ (new, not used) and a samsung 32gb micro sd card for it. at the beginning i didnt have the official power adapter so i have tried it with an older samsung phone adapter and cable and i was able to power up the pi, connect the webcam but after every octoprint update i couldnt even start the octopi, and couldnt connect it with the printer because if i have had it connected i couldnt print, always stopped the print by the pre-heating phase already. so i thought ok the power adapter (5v/1a) is surely not enough so i have bought a strong 5v/2.5-3a adapter, since then i can do the update on the octoprint, install the plugin i need (raisecloud, we have raise3d printer too so i would be happy to watch our printers via 1 app) but i think my usb ports are dead a** now, all 4 of them.. i have tried to reflash the card, already 3-4 of them but im having the same issue, the first power adapter i have used, another cables, but none of them working. like i said i have had a working webcam at least at the beginning, but now i cant even see the webcam and im really sad about this thing, because i like the idea, but im already trying to set the berry up already for 2 months now i think... so the problem is that my usb ports are dead, tried also to plug only a small usb led into it or keyboard, mouse, it just simply doesnt wanna recognize them...
already thinking about to buy a new raspberry pi 4 but a complete kit from somewhere hoping that i cant fck it up but yeah, im not so sure about it... the webcam is an ausdom model i have had lying around but it was working at the beginning i only needed to write the -y at the end of the command line.
i dont want to use octopi for anything complicated only to monitor the printer if im not there and make some timelapses... so sorry if its a little bit long but im trying to give every information you guys need to help me out... thanks in advance!

So RPi 3B+, 5v 2.5a power, hdmi monitor?, and a keyboard and mouse in the USB slots. See what the monitor says as its boots up.

Can you SSH into the RPi after its booted up? If so (then you don't need the monitor), type dmesg >dmesg.log and post that here.

i didnt attach it to a monitor yet but i can use ssh into. sorry yesterday i havent seen ur comment. dmesg.log (113.3 KB)
i hope this is what u need :neutral_face:

Could be a backpowering issues:

The dmesg.log is filled with:

[  419.508439] usb 1-1.1-port3: over-current change #867
[  419.748408] usb 1-1-port2: over-current change #581
[  419.748440] usb 1-1.1-port2: over-current change #868
[  419.988420] usb 1-1.1-port3: over-current change #868
[  419.988453] usb 1-1-port3: over-current change #581
[  420.228435] usb 1-1-port4: over-current change #581
[  420.228468] usb 1-1.1-port2: over-current change #869
[  420.468420] usb 1-1.1-port3: over-current change #869
[  420.468452] usb 1-1-port2: over-current change #582
[  420.708441] usb 1-1-port3: over-current change #582
[  420.708473] usb 1-1.1-port2: over-current change #870
[  420.948435] usb 1-1-port4: over-current change #582

I fed one of those error messages into Google and it appears to be related to broken hardware. I'm afraid your RPi 3B+ will need to be replaced.

Its not even connected to the printer yet only the webcam is attached :confused:

Thats what i was thinking too :confused: but its a bit frustrating that only after 1 or 2 months it gets broken .. i wasnt even able to make one video with it ..

Is this one of the Creality printers that puts 24v on the USB connector?

its an ender3pro but its switched to 12v so i dont really know if it does that :confused:

See the end of @Charlie_Powell's post: Backpowering problems. Not saying that this is an issue with your printer model but 24v or 12v on the RPi USB port could potentially fry the RPi. Just be careful with your replacement RPi and block the +V USB line before you plug the printer in.

oh i see now, yeah but this log what i have sent today is when i have only the webcam attached and the printer isnt connected, i think i get the same then if i connect the printer too. i have tried a mini usb lamp from ikea and its also not working if i connect it :frowning:

Not sure how or when but the RPi 3B+ that is giving those dmesg messages most likely has no working USB ports. The rest of it is fine and could be used for any application that doesn't need USB ports. From the posts I read, a hardware geek could maybe fix it but that's way beyond my pay grade (and this forum).

tried out this tape hint but no luck... tryin to send it back to my vendor its only 2 months old maybe i can get a new one..
thanks for the help!