Flashforge Creator Pro (2016) stuck in "cancelling" state

What is the problem?

During printing (with a Flashforge Creator Pro, 2016 model (bought new in Aug 2020, just before they released the new v2 of the printer...)), if I cancel or pause the print, the connection status gets stuck in "Cancelling".

What did you already try to solve it?

I found a bunch of earlier threads on this (dating back to 2018):
This one.
And this one....
(I didn't want to necro really old threads, hence this new post)

I have tried disabling "log position on pause" and "log position on cancel". Neither option fixed the problem.
I also tried cancelling a print and then clicking the "Fake acknowledgement" button, but this seemed to do nothing (nothing appeared in the terminal other than the printer's regular reporting of temperatures).
I tried clicking the "Fake acknowledgement" button a dozen or so times. Eventually a message was sent (which I saw in the terminal), but the connection status remained "cancelling". Tried a few more times and eventually the connection status changed to "operational". However, I was still unable to actually control the printer (I couldn't move the extruders using the X/Y buttons on the Control tab, for instance. I was able to turn on the print bed heater, but I was unable to turn it off.

Each time I get stuck in this situation, I power-cycle the 3D printer and reconnect and that fixes things. But that's not ideal, for obvious reasons...

As per this, I tried also manually sending M114, but nothing seemed to be sent (no outgoing message to the printer appeared in the terminal above). I tried this multiple times without success.

Have you tried running in safe mode and if so did it solve the issue?

My printer cannot be controlled directly by OctoPrint; I have to use the GPX plugin.
If I reboot into safe mode, OctoPrint cannot connect to the printer at all.

Instead, I disabled all plugins that I have installed that are in the "third party" tab of the plugins manager, except for the GPX plugin, and retried all of the above again, having identical results.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Here is my entire logs folder: logs.zip (296.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version 1.4.2, Python 2.7.16 (as per the first reply, I have since upgraded this to use Python 3.7.3).

Raspberry Pi 4 Model B 4GB, RPi v2 camera board, set up last week using OctoPi's disk image (v0.17.0) from here. OS: Raspbian Buster.

FlashForge Creator Pro (v1/2016 model)

Printer firmware: Sailfish v7.8.

Thank you in advance.

I just upgraded OctoPrint to use Python 3 using the script described here.

Here's a copy of the stdout: Py3upgrade_stdout.zip (2.2 KB). It seems to have been successful. The upgrade script couldn't reinstall the GPX plugin (which is vital for controlling my printer), but I was able to manually install the GPX plugin via the Plugin Manager after the Python3 upgrade.

I then tried to start and cancel a print again, with the same results (print started fine, but gets stuck during cancelling). I power-cycled the printer again to regain control. Here's a serial.log file from a cancelled test-print after the upgrade to Python3: serial post Py3 upgrade.log.zip (2.6 KB). (during this test, I started a print and waited a few seconds for the print bed heater temperature to be set, and then I cancelled. I cancelled before it even started to move the extruders etc. as it doesn't seem to make any difference and time is short...).

Upgrading to Python3 has not resolved this issue.

Bump. :slight_smile:

I have raised this as a new issue on the OctoPrint GitHub page.