Help Connecting Ender S1 Pro to octoprint

What is the problem?

Ender 3 S1 Pro will not connect to octo print

What did you already try to solve it?

First I used the commandes lsusb and dmesg to confirm that I have indeed selected the correct Serial Port,I have the Baudrate set to auto, first it "Detecting serial connection" then it hangs on "connecting" intill it times out and i have changed the timeout time to 20 secs

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (360.6 KB)

Does anyone have any ideas for trouble shooting tips :slight_smile:?

Hello @ChopperOllie !


  • The GPX plugin only makes sense when you run a FlashForge and older MakerBot printer.
  • The OctoKlipper plugin only makes sense when you run Klipper firmware.

For you run a Crealtity printer, try these:

With/without SD card in the printer's SD card slot.

How did you get OctoPrint onto the Pi? What OS are you running?

This path is not genuine:


Usually it is pi, not pie

I will try the tap trick and tell you what happen, for this problem "/home/pie/oprint/lib/python3.9/" that i believe is because the username I choose is pie and not pi, also thanks for responding. :slight_smile:

1 Like

You also don't need both temperature fix plugins for creality, I'd recommend sticking with the Creality-2x-temperature-reporting-fix (0.0.4) one and removing the other. And UI Customizer is way better than Themeify.

Don't change the username from pi.

technically with the octopi image from pi imager it doesn't matter if you keep the name pi or not.

Thanks, anything to get this working

You could try manually setting the baud rate to 115200 instead of using Auto. And the 5v usb power isolation (tape fix or other) is definitely something you want to do.

sadley after forcing the bitrate and isolationing power still same issue, any other ideas (484.5 KB)

Does anyone have any other ideas I can try, even if it seems stupid I'll still try it, anything to try and get it working :slight_smile:

You may try with pronterface to connect to your printer.

Also try different USB cables.

one slight change all my cables are bad even though they can transfer data from my pc to my phone, what is a known working cable that is good for what I am trying to do?

Just to confirm, you're plugging into the front usb-c port on the printer, next to the SD card and OctoPrint sees the port, just never is able to connect properly?

Correct i am plugged into the usb port next to the sd card slot and i am also using the Tape Trick

After me looking into my Ender S1 Pro a little more I realized it was indeed using kipper, After watching this video Installing OctoKlipper On Your 3D Printer

For me because I have the ender 3 S-1 Pro The chip that I had was the "Stm32F103"so that is the firmware I did, if you do it wrong you might get an error saying "Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Must home axis first: 0.000 0.000 10.000 [0.000]"

and I did do it wrong so I found this nifty link to help me. GitHub - synman/Ender-3-S1-Pro-Firmware get my printer on the correct firmware.

Then I was getting the error "mcu 'mcu': Unable to connect" and i realized it was not plugged in so that fixed that and then I was good.

HopeFully this helps someone else :slight_smile:

1 Like

I almost assumed it.

@synman strikes again!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.