I'm getting a kill code on my ender 3 max running octoprint

Once in a while i will get a kill code on my ender 3 max running Octoprint and it cancels the print and makes you restart the printer also. seems to do it the most during a filament change. sometimes when the bed and extruder is warming up.

What did you already try to solve it?

Nothen. not sure what to do to fix this

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Never tried

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230717115657.zip (689.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.9.1, pi 4B 8 gb, ender 3 max, chrome, windows 10,

Hello @tgrinnall

This is the weirdness of Creality firmware.

The problem is, that the firmware does not report the issue of the | Recv: Error:Printer halted. kill() called!

Creatlity firmware can behave strange when connected to USB.

Please try these:


With/Without SD card in the printer's SD card slot.

1 Like

Yeah as @Ewald_Ikemann already said it's really hard to figure out what went wrong if the printer doesn't tell us what the problem was..

I don't think that it was an USB related issue, but can't rule it out.

Can you see what firmware version is installed?
Maybe while the printer is powering on, or with M115 in the terminal or somewhere in the screen menus?

i was getting a low voltage error but i was told to turn that warning off since it really isn't a low voltage going on. so maybe the tape would fix both issues

If the Pi reports low voltage, there is low voltage

Who said that?

If you get a low fuel warning in your car you can put tape over it to make it go away - but that doesn't fill your tank :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.