I'm lost! Can't do jack!

I connect the Raspberry to the tv and everything booted BUT...there was no IP address connected and I could not login using pi and Raspberry, and I tried it several different ways capitalizing etc.
I use ++ to edit and changed country and took off comments# put in the correct net info saved backed to the drive. I save the SSH without any file type and it goes on the drive but when I have taken the card back to do some editing, the SSH has to be done again.

What I need is:

Login (not pi)
Password (not Raspberry)
why the SSH does stick
why it doesn't connect to the network with the correct info verified.

Also, I can't seem to use Discord. Asks for email and password then tells me that the email is already being used so it won't let me chat.

I thought this was supposed to be simple.

Login user: pi
Password: raspberry

Unless you are using a different distro, could you fill us in with some more detail about what you are actually using? Just like there is in the prefilled template...

I'm afraid I don't understand what you mean by 'saving the SSH'. Is this a file? SSH is a way to remote connect to the Pi, you can't save it. Unless.. You are using Raspberry Pi OS, where SSH is disabled by default. Again, what do you have installed.

Anyone's guess. There are a couple of things that can be tried to troubleshoot, but lets get the above sorted first.

Like I've said, I tried those passwords. I'm following a lot of youtube videos. Most said that after adding your network, create a file (no extension) called SSH. It shows up on the drive but when I need to try something else, it isn't there and I have to repeat the save.
I flashed Octoprint I haven't added Raspberry Pi OS unless it tagged along with octoprint.

Again those password didn't work and it doesn't see the network. And I've downloaded and flashed a dozen or more times. I have triple checked the addition of the network and password, and yet they are between the quotes and I took off the #. I just can't figure out where the problem is. Which software, hardware, or installer.

Thanks for your help.

You did not mention if you are using OctoPi. With OctoPi, SSH is activated by default.

Probably, in this case, you flashed OctoPi? Since OctoPrint can't be flashed to an SD card. See also What is the difference between OctoPrint and OctoPi? Are they the same thing?

Not required using OctoPi, since SSH is enabled by default. And if I remember correctly, the file is swallowed whole by the Pi on first boot, so that'll be why it keeps disappearing. The Youtube videos you were watching were probably not for the right thing.

Nothing else I can do about that, since pi / raspberry is the default password for OctoPi, unless you include an octopi-password.txt file, with some things to change the password. Which seems unlikely to me.

However, I think you may be trying to run before you can walk. With no network, SSH will not work - but, maybe you have the username/password prompt, since you know it doesn't work? This is where I am confused.

The easiest thing for you to do, to diagnose network issues is to connect a HDMI display (TV, monitor, anything) to the Pi so you can run some commands to see what the Pi thinks is going on.

You can find lots of OctoPi specific troubleshooting in the post linked below. There are some things you can try there, such as the output of the diagnostic commands, from this section of the post

How could I tell? Downloaded from Octoprint and tried at least 4 different image flash. There isn't a SSH file that is why I created a file SSH. And if it is activated by default, which makes sense, it's not working either.

I plugged into monitor and added keyboard and mouse.

There is a documentation:

1 Like

Yes, I guess I assumed that everyone uses Octopi but it comes from Octoprint. :slight_smile:

Unfortunately there is so much inaccurate information on that page that it is just confusing.

What's confusing?
It's a step by step install and setup manual.

Mind pointing out which bits? Seems to be correct for me.

Maybe at least 75% of installs use OctoPi, but it is significant enough that it is important you tell people exactly what you are using.

Have you tried any of the OctoPi specific troubleshooting I linked to you earlier? That exact post is even linked from the setup guide, if you are having problems.

1 Like

I followed everything point by point. The confusion is octopi.local when it hasn't been used for a long time, why is it still there? And when the information says to do this or that, and there isn't an option for this or that...that's why I'm lost.

I just flashed and booted for the 20 time. The login pi and password Raspberry (tried upper and lower cases) do not work.

What do you mean by that?
There a two ways to connect to OctoPi

  1. The IP address of the Raspberry Pi or
  2. http://octopi.local

Where exactly?

octopi.local doesn't work either. Goes to google Have you tried it lately?

Try putting http://octopi.local...

Your browser is probably thinking you're searching not a website. It works perfectly for 1000s, just now.

octopi.local ’s server IP address could not be found.

You also entered the http:// ahead of octopi.local?

You need to fix the WiFi issues first. But then you are somehow struggling with the password. Not sure what else to suggest until you get it fixed.

I'm wondering if you are entering the password in the wrong place. Can you share a screenshot of where you are entering pi and raspberry, exactly like that. I can tell you 100% this is the correct password.

yes, copied what you sent.