Kingroon KP5L Newbie Issues

What is the problem?

A few. I have completed a fresh new install. I need some guidance. I have downloaded a few plugins.
I have a Pi 400, with a no name Webcam (I have ordered a C270 Logitech), but it keeps dropping out after @ 15-30 minutes. I noticed Octoprint may not be connected, and if I do connect it, my KP5L stops. I have also noticed that the temerature does not always update, and the progress meter does not update. Also, it is no longer connected ? Maybe my MAc went into standby?

What did you already try to solve it?

A new install

Have you tried running in safe mode?

Not yet, as I didn't know there was one.

Did running in safe mode solve the problem?

Not sure how to

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Unsure how to do this

Additional information about your setup

Latest Stable version DL today, 1.9.1 ? OctoPi version , Kingroon KP5L, firmware (unsure, just what came with the unit), Google Chrome, MacOS, ... **not sure what else to add. I was using Lychee, but I did my last 2 prints under Cura.


Sorry, I am a Noob.

Hello @Darug2300 !

Blue words are links to further information.

Thank you. I'll give it a try when it stops printing. I sometimes find that connecting etc, can stop a print. Might be my KP5L?
I have a new supported Webcam that arrived today, that seems okay so far. A Logitech C270.

The new Logitech c270 seems to work better than the other wecams I've use on my Pi400. Biggest issue I have is not being able to zoom out. I read another post, and I'll look at that. One Plugin zooms in (but not out).
I tried Safe mode, but still no progress meter. Temperature is working well, but it doesn't seem to respond to a remote temperature change.

So, the c270 webcam runs really well.
I have run it in safe mode, but I still have issues.
The status doesn't always update, other than the temperature. Currently the state is Offline after Error -
SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
If I press Connect, the device stops printing, so I have to clean reload etc.
I have also tried uploading files to the printer remotely, but that doesn't seem to work either (I'll replicate that later) (109.4 KB) (1.6 KB)

The reason for the stop on reconnect is that when Octoprint connects, it basically takes over the printer. The reason that it seems to continue to run when it disconnects is because you are not running the print from OctoPrint you are running it from the SD Card. So when OctoPrint has communications issues with your printer, it disconnects it self. You might get some better detail if you turn on the Serial logging and reproduce the issue. Just remember to turn it off. If you forget it cant get big and even over time start to fill up your Pi SD Card.

Once you have the Serial.log send it along with an updated systeminfo bundle. << To get this, as @Ewald_Ikemann said, the blue words are links to info on how to get it. To turn on Serial.log you can click on that link to find out as well. I have a good number of KR printers. They are good quality for the price point but the stock Firmware is typically pretty custom and based on a very old version of Marlin. So there could be things that your KP5L just does not support.

You could also do a search on communications issues in in the forums and see if you find something that could help...

Like are you using a good quality cable?
Is the cable as short as it can be?
Is the cable shielded?
Does the cable running past the servo cables? Does it have a ferrite bead on it? (I have neve needed this one but some say it has fixed there issues.)
Are you blocking the power line form the printer to the Pi? There are multiple ways to solve this.
This thread has a number of them listed.. From the quick and risky to the costly and unnecessary. Also a few in the middle ground.

Thank you for the in-depth reply. I'll try the serial log later.
The USB cable is the stock standard 50cm one that it came with. I'll try another cable such as the Belkin one. It comes straight out the front, down to the Raspberry Pi 400 that is in front of it. I don't recall seeing any with the ferrite bead on it.

I'm still using the original FW, and I've tried looking for a version number, but I have been unable to locate it. The original MicroSD has gone missing. I have also read on FB, that a few people have had issues after updating the FW.

I'll look into the 5V possibility. :slight_smile:

I purchased a shielded USB cable, and put tape on the pin. It seems better, but progress and layers still not showing at my end. I'll do a serial log in the next few days.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.