Linux Running OctoPrint but Can't Connect


#1

What is the problem?

I have a fresh install of Linux Lite (i386) running on an old computer, connected to my local network via Ethernet. I followed the guide to build and install OctoPi (I mean OctoPrint) and everything seems to have gone smoothly, however, I an unable to access OctoPi (I mean OctoPrint) in a browser via my other computer. I can ping the IP of the Linux machine but ocotopi.local times out.

What did you already try to solve it?

Restarted the laptop, tried different browsers.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Latest version of OctoPrint, Linux Lite 3.8


#2

Use the IP in your web browser. Otherwise, you probably are on an OS that doesn't work well with the avahi/zeroconf/bonjour that broadcasts octopi.local. Read all of this to see fixes/workarounds/whatever, or just use the IP.


#3

Thank you for the response! I am able to find the IP of my computer (using ifconfig in linux) and I have tried the IP in my browser, with and without the port number (:5000), but it times out just like octopi.local. I am trying to access the server from a Windows 10 machine. The windows 10 computer shows the name of the server under "Network>Other Devices" but if I click on it I get a message saying it cannot connect.

Could you elaborate on " Otherwise, you probably are on an OS that doesn't work well with the avahi/zeroconf/bonjour that broadcasts octopi.local"?


#4

Read the link above for stuff about octopi.local. May as well ignore that until it is working by the IP. But if the IP in your browser fails, Octoprint must be failing. Share your octoprint.log.


#5

Here's a link to octoprint.log.


#6

Hmm, it seems to be loaded. If you can't get to it via the IP on port 5000, try this while ssh'd into the machine:

curl http://localhost:5000/


#7

btw octopi is for the raspberry pi


#8

Hmm. I installed openssh-server but I can't putty in. I can't say I'm a linux pro, if I'm missing something let me know. I just installed the package on the Linux machine and ran Putty on the IP address of the server. The connection times out. I can still ping the server.


#9

Good point, I edited it.


#10

Hello @Chuppster,

first you need to sort the access via IP and SSH out. Then you can go on with the OctoPrint web frontend.

  1. What IPs have you assigned to your Windows machine and to your Linux machine?
  2. Which Linux distribution are you using (Debian/Ubuntu/Arch/Gentoo/....)?

Then we will try to sort things out.


#11
  1. DHCP has assigned 192.168.1.63 to the Linux Server and 192.168.1.64 to the Windows machine.

  2. I am running Linux Lite, which from my understanding is a branch of Ubuntu.


#12

OK, then. The IPs match up (most probably).

Can you ping the linux machine from windows?


#13

Okay, I was talking to a co-worker and they suggested disabling the firewall. I just tried that and now SSH works! I tried octopi.local but that didn't work, however when I used the IP:5000 I got it! So, it seems to be working for the most part!


#14

Which firewall? On the Windows machine? Then you need to configure it to work with the linux machine's IP address.

I am honest, I do not like zeroconf/bonjour to get the name of the printer. Do you have full control over the network? Can you assign static IPs? This is always a good idea for machines that run services.


#15

I disabled the firewall on the Linux machine. It is my personal network and I'll assign static IP's in the future.


#16

You know how to tweak your firewall? I do not know how advanced your linux knowledge is (no offence).


#17

Try adding a c:\windows\system32\drivers\etc\hosts entry for the octopi box with the address you discovered. You'll want to do a Start -> Notepad -> Open As Admin for this to work. Save it as "hosts" with double quotes like that so that it doesn't get stupid and try to add .txt to the end of the filename.


#18

I've tinkered, but most of my experience with it is running programs, not setting them up. I do now know how to tweak the firewall but I will be looking that up once I get some time.


#19

I really don't mind typing in the IP, I just want things to work!


#20

Sounds like your Linux firewall was tweaked to allow the inbound port 22 service for ssh, allowing that to work. I'm guessing that since port 5000 isn't <=1024 then it's maybe allowed by default in your firewall, so you got to the OctoPrint web application.

Name resolution (turning octopi.local into that IP address) could be cheated like I suggested or you could add the Bonjour service to your Linux server and to your Windows workstation.