Marlin not taking commands when controlled via USB

What is the problem?

When I connect my Ender 3 Pro via USB to a PC or Android device it connects and I see it in the corresponding software (Octoprint, Cura...) but when I send a command to it nothing happens. The screen either shows "Homing Failed: PRINTER HALTED Please Reset" or freezes or the board even beeps (when heating the bed)

What did you already try to solve it?

Tried different devices, software (Windows/Cura, Octo4a), and cables. Setting baudrate.

Have you tried running in safe mode?

Safe mode won't start. But I thinks it might be a problem on the Marlin side...

Did running in safe mode solve the problem?


Systeminfo Bundle (25.2 KB)

Additional information about your setup

Printer: Ender 3 Pro, Marlin 1.0.1, 4.2.2 board
Octoprint 1.8 (through Octo4A), Windows 10, Cura 4.13.1

Hello @Opadera !

For this is Creality firmware try wit/without SD card in the printer's SD card slot and/or:

I tried without SD card, same problem.
Will try with taping later, but that's an OTG related problem is it? I get the error while connected to a PC as well.

Maybe factory reset/firmware update?

ok, I feel stupid posting this but others shall benefit from my stupidity. Here's the solution:

You have to turn the printer on (manually). :slight_smile:

When I connected the device the printer screen turned on and I assumed there's a relay switch connecting the PSU but apparently there isn't. You still have to physically flip the "on/off" switch on the printer. It failed when I sent commands because the e.g: motors used more power that was available through the device.

1 Like

That's something else you will want to address:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.