Neither Instance Updating to 1.7

What is the problem?

I have two instances of Octoprint for both of my printers on separate RPi3 Boxes - Neither instance is updating to new 1.7

What did you already try to solve it?

Removed some new plugins that were recently added since other updates.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Attached

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint: Version 1.6.1
Ocotopi: Version 0.16.0, running on Raspberry Pi 3 Model B Rev 1.2
Printer: Ender 5+
Firmware: Th3d Unified 2
Browser: MS Edge chromium
OS: Windows 10 Version 21H1
octoprint-systeminfo-20211011163513.zip (35.3 KB)

All is explained in the post above

2 Likes

FYI, in this part of that post:
"Once it has run its course, you can uninstall it again."
it makes it sound like its optional to un-install the fix. It was not for me, it had to be un-installed as well or upgrades would still fail.

The only thing the plugin does is literally run pip uninstall logging. Nothing more. I have no idea why you had to uninstall it again for the update to run through, the only thing I can think of right now is that something got cached somewhere and you needed another server restart (triggered by the uninstall) to clear things up.