New OctoPi build causing issues with CR10Pro V2

What is the problem?

My last PI 4b died (running 0.86) so I have been printing via my laptop connected through Cura for a couple of weeks now. I got my new PI and installed the newest 1.0 stable. Got everything up and running on my PI without issues. Connected the printer and thought things were good. Started installing plugins and rebooted the PI. I went to run a bed visualizer mesh and normally I would have heard the BL touch cycle twice and then start to do the bed leveling. This was not the case, it cycled one time and then stopped. I tried to put a mesh into the machine by attempting to run the auto-level from the machine screen and the printer was not responsive.

What did you already try to solve it?

I unplugged the printer via the USB cable from the OctoPrint and the 3d printer still not respond. I power cycled the printer and then attempted to do the auto-level without OctoPrint plugged in. This worked without issues. I plugged in the USB cable for the OctoPrint and it chimed like I would have expected but then I attempted do a bed visualizer mesh again and it did the same thing. I could no longer control the printer from the screen and I got an error message about the firmware not responding properly. I do NOT have custom firmware. I have the same Creality current firmware that I did prior to going to OctoPrint 1.0.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Same behaviors exhibited

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (76.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


The main issue is the printer itself.
It frequently reports failed probings like this:

2023-03-15 21:32:44,274 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Probing failed
| Last lines in terminal:
| Recv:  == T:20.62 /0.00 == B:59.95 /60.00 @:0 B@:127
| Recv: echo:busy: processing
| Recv:  == T:20.62 /0.00 == B:60.00 /60.00 @:0 B@:127 W:4
| Recv:  == T:20.62 /0.00 == B:60.19 /60.00 @:0 B@:127 W:3
| Recv:  == T:20.62 /0.00 == B:60.31 /60.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  == T:20.62 /0.00 == B:60.32 /60.00 @:0 B@:0 W:2
| Recv:  == T:20.62 /0.00 == B:60.37 /60.00 @:0 B@:0 W:1
| Recv:  == T:20.62 /0.00 == B:60.35 /60.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  == T:20.62 /0.00 == B:60.37 /60.00 @:0 B@:0 W:0
| Recv: ok
| Send: M300 S1000 P500
| Recv: ok
| Send: M117 Creating the bed mesh levels
| Recv: ok
| Send: M155 S30
| Recv: ok
| Send: G29 T
| Recv: Error:Probing failed
2023-03-15 21:32:44,275 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Error"
2023-03-15 21:32:44,280 - octoprint.util.comm - INFO - Force-sending M112 to the printer
2023-03-15 21:32:44,346 - octoprint.util.comm - INFO - Changing monitoring state from "Error" to "Offline after error"

You may have a look on these:

Also please avoid to powercycle the Pi. Sooner or later you will get more serious issues due to a corrupted filesystem on the Pi's SD card.

I looked at both of those and postings and neither are applicable at this point. If the Octopi is connected to the printer, functions that should still work on the printer just don't. I can't move the print head, I can't run a Z adjust, pretty much the screen stops working. It truly is when I plug in the printer to the Octopi that both freak out. If I unplug from the Octopi and power cycle the printer, all of the functions of the printer continue to work. It seems like some type of communication issue. But if I connect the printer to my laptop, it works just fine as well (same cable).

Also, I have manually leveled my bed again and with Octopi disconnected, ran the mesh and it worked just fine. Everything works fine except when connected to the Octopi. I had zero issues with Octopi previous edition. I have tried multiple cables to no avail. All of those cables work when connected to the laptop.

I grabbed another SD card and threw .18 and 1.8.7 on it and I am having the same issues where the the printer screen functions do not work when connected to the Octopi. (109.4 KB)

I uploaded the system bundle from the 0.18 install with 1.8.7 on it.

For you are running the genuine firmware on that printer, you may try a different one.
Creality firmware is known to be a bit quirky.

I can fully understand the response. The issue that I have is that it worked absolutely fine previously. I am not sure what has changed from before to now other than the Raspberry PI that I replaced and the fact that I did a new build. Totally infuriating. I work in IT so I am used to things not working and I have been using Linux since 1998 but this baffles me. It has to be something little and stupid. Just don't know what it is yet.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.