No Connection to Printer (Ender3 V2) with Raspberry Pi 3b -Solved

What is the problem?

I cant get any Connection to my Printer, i tried a few things other usesers had Sucsess with but nothing worked for me.

What did you already try to solve it?

I changed the usb port i cahnged the usb cabel i re installed octoprint on the raspberry pi (total new flash with new download from offical page) i unplugged the web cam i did firmware update from the raspberry pi (sudo apt uptdate/upgrade) and i updated the octoprint firmware via the web interface.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

logs attached...


Additional information about your setup

raspbarry pi 3b, ender 3 v2 with the pre installed firmware version :

octoprint.log (125.2 KB) serial.log (3.1 KB)
octoprintinsafemode.log (141.6 KB)
serialinsafemode.log (609 Bytes)
serial.log (3.1 KB)

Hello @Ogram91 !

You have an constand underpower issue:

2021-03-11 16:17:04,025 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

Also, I strongly recommend not to pull the power off the Pi. Than can lead to a corruption of the filesystem of the SD card.

For your issue: Have you tried this:?

hey thank you for your help i have an update... the under voltage is solved now the 5 pin is taped and the conection issue is defenetly on the printer side. it was able to be deteced by my windows pc but with the error mesage (Code 43).
i will power of the pi in future.

but i think the problem is the usb micro port on the printer... its not able to detect for the pi

i propaply will get in toucj for a replacment with creality due to that the printer is only 4 weeks old.

or do you have an better idea? you want new log files? wich ones?

You may can test with pronterface to check if the printer board can connect via USB.

i tried on the raspberry pi the "lsusb" and "dmesg" and its not listing the printer. What is "pronterface"? is it a program to check the conection or just other software wich can interact with the printer?


Pronterface is contained in and can be used instead of OctoPrint to connect to a printer. I've never used it on an RPi but I do have it installed on Windows 10. Many slicers also have a way to connect to a printer via USB.

The goal of this exercise is to determine if the printer's USB port is functional because if it isn't, OctoPrint won't be able to connect to it. If it is functional, then we will know we have to look elsewhere for the reason why it doesn't work in your case.


okay sounds good! i will install it and try it the next days and come back to you! thank you!

You could also SSH into the PI with putty or MobaXterm and see if the USB port is iterated in the /dev directory. You could plug a flash drive in and see if it is visible to test the PI USB ports.

I kept getting no-connection after 3 days of use until I reflashed/installed OctoPrint image again

Update, for me i solved the probelm, it was a combination of a brocken usb port on the printer and a strange usb cable i used (even when changing the cable it wouldnt work) i got a replacement from creality, and now it works! thank you all for the help!