No connection to Sermoon D1 via USB

What is the problem?

I cannot connect to Sermoon D1 via USB.

Here's what the log file shows:
Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"

What did you already try to solve it?

Reconnected with other USB cable

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.107 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true : true
connectivity.resolution_check :
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1500
env.hardware.ram : 8204619776
env.os.bits : 32 : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.6.1
systeminfo.generator : systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

When the printer is off and i connect the USB cable the printers display is booting.

Hello @Steakgriller

Then you may try this:

1 Like

Hey @Ewald_Ikemann,

first of all i'd like to THANK YOU for the stunning and fast reply.

I'll try your tape hint and come back later with results.

Thanks again for your kind support. :metal:

If there are 0 port/baud rate candidates to test, then the Pi is not recognising the printer at all. Usually the first cable people try is a charge-only cable, and it takes some attempts to find one that works for data transfer as well.

You can try connecting different devices, or connecting the printer to a PC and see if that recognises it.

To test the USB connection on the Pi, find the terminal via SSH and enter dmesg -w, this will watch the system logs. Then unplug and replug in the printer, you should see messages relating to 'new USB device'. If you see nothing, the cable is probably not working.



I tried two different USB-cables with the tape. None worked for now.

@Charlie_Powell thanks for your reply. I'll have a look at the Pi-logs and come back later.

I cannot believe why i have so shitty USB cable at home. I tried a third cable and it worked.
@Charlie_Powell thanks again for the hint. @Ewald_Ikemann i also used your tape hint and the USB connection is working well. However it's working with and without tape. But, i will keep the tape on it to prevent voltage issues.

First test: The first test to HOME the printer was a total mess. The bed went straight up and didn't stop going upwards. OMG! I hope nothing is damaged. No idea where i did something wrong 'cause i guess i configured the printer profile the right way.

Anyways, thank you guys for your support. :heart: