"Not SD printing" - won't shut up

All my printer will serial write is "Not SD printing" and "Wait". It will not respond at all. It happened just about time I A) started and M112'd out of SD print B) upgraded Octoprint to 1.6.0 stable. Wait - now it's printing from SD but still is reporting that it is not. Its marlin 2.0.8 bugfix. First time this ever happened.

WRITE HERE

What did you already try to solve it?

I started and stopped another SD print and it still is happening. Also safe mode has no effect. Now just tried to print from octoprint - no good either. Just spat thru the commands and responded "ok" but did nothing - this was in safe mode too.

I loaded the firmware again and this didn't change anything. But it did reset twice spontaneously...
Ok I now loaded back in the stock creality firmware and it is still acting up, won't even shut down with a "M112" although it says it does. It'll print from SD card fine but still reports it isn't. It's half brain dead.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

Not

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version 1.6.0 , OctoPi version no idea, ender 3 pro, marlin 2.0.8 bugfix, chrome, windows 10

Could you reproduce and attach bundle logs?

Thanks here are some of the logs. I did have the printer on it's side to attach springy feet and the display lit twice due to Y motion - i think it should handle that (pet peeve it doesn't d/c servos while off).
octoprint-logs.zip (140.6 KB)

When you say it's now printing from SD are you printing direct from the printer and not from OctoPrint? Can't say I'm that familiar w/ SD print but some firmware configurations don't report anything back over serial when printing from SD. Some will even reset when you connect. Have you tried disabling SD support in OctoPrint and print from there instead?

SOLVED. It was silently failing to connect to serial and then connected to virtual printer and vp will spit out "not sd printing". It would be nice that it wouldn't slam me to another connection silently. It's like asking for amazon, but it was too slow to respond and instead of error, it sends you to aliexpress.

Under settings > Virtual Printer you can disable it.

Virtual printer isn't enabled by default. If you want to connect to a specific printer port, select that. If you select AUTO, it will work through all detected ports until it finds one that answers (there's no other way to do this), so if you have a misbehaving regular printer and the virtual printer enabled, yeah, it might go to that, that's how auto detection of a printer is supposed to work, do your best to detect a printer.