Not working heated bed for makerbot replicator 2

Hello! There is such question. Not working heated bed for makerbot replicator 2x. On the printer, everything works, OctoPrint Version 1.3.10

Do you have the GPX plugin installed?

Yes, GPX plugin installed

Ok, do you have the logs?

octoprint.log (54.1 KB)
Yes, I attach the log

Thank you. serial.log would be quite handy, so one can see what is sent to the printer.

Okay, when the printer completes the current task, I'll write serial.log

1 Like

I attach the serial.log (5.1 KB)

I found this here:

2019-03-06 08:19:20,320 - Send: M140 S50
2019-03-06 08:19:20,353 - Recv: ok
2019-03-06 08:19:20,356 - Recv: // echo: (line 4) Semantic warning: M140 cannot select non-existant heated build platform

Either your printer does not have a heated bed or there is a fault in your firmware.

Referring to this, it does not have.

it seems so. But the printer works, and the bed is) there may be an error on the part of octoprint? By the way, I reinstalled octoprint, broke the image from power off. Before reinstalling everything worked

Maybe you changed the slicer settings?

no, all the usual settings

This M140 S50 command is produced by your slicer. The slicer should know that there is no heated bed.
The message // echo: (line 4) Semantic warning: M140 cannot select non-existant heated build platform is produced by the firmware. When there is nothing to heat, it can't heat. It's not a fault of OctoPrint.

1 Like

Thanks for explaining

What slicer are you using?

original MakerBot Desktop. But when I try to control the table temperature from octoprint, it also doesn't work

So you do have a Replicator 2x or a Replicator 2?

Your serial log said this:

MACHINE_TYPE:r2 This should be the Replicator 2, not the R2x
And the R2 has no heated bed.

Have you made a firmware update before?

Rep 2x. Firmware update did not. I'll check the firmware.

The problem was in configuring GPX. It was necessary to specify a printer Replicator 2x