Octopi not connecting to CR-10 v2

What is the problem?

when I press connect in the octoprint web server, to connect to my printer it tries to connect but doesn't succeed.

What did you already try to solve it?

enable wait for start on connect option, get an otg data cable, correctly power the raspberry pi
run "dmesg" in ssh to see if the printer was seen by a usb driver, (it was). manually add the usb port to octoprint. manually set the bouderate and USB port in octoprint.

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version: 1.8.1, OctoPi version: the latest stable version, printer: creality CR-10 v2, firmware: merlin engine from tiny machines, browser: chrome , ... as much data as possible
serial (2).log (1.6 KB)
dmesg output.log (21.0 KB)

Hi

Which Pi is it?

respbarry pi 3 b+

Already tried the usual "Creality" tricks?

Try with/without SD card in the printers SD card slot.

I tried both proposed solutions but it doesn't work.

I still get the error: " No working connection parameters could be found. Are you sure your printer is physically connected and supported? Refer to [the FAQ] (OctoPrint can't connect to my printer - FAQ - OctoPrint Community Forum) for help in debugging this."

and state says:
" State: Offline after error
No more candidates to test, and no working port/baudrate combination detected."

Different USB cables?

i tried but that also doesn't work.

How many cables? Are you sure they are made for data?

like 4, im now testing two i found from external hard drives. but i thought it might also be important to know that the pi only works with an ethernet cable, wifi does nothing

The connection to your local network (WiFi or LAN cable) does not influence the ability of the Pi to connect to the printer.

the new cable changes nothing. If I select the correct port and bauderate and then press connect, it says connecting and then just stops

Can you enable the serial.log and share it after the connection attempt.

BTW: Can you connect to the printer from the PC using pronterface?