Octopi USB issues on Raspberry Pi B+ with Ender 3

Just to clarify, I did monitor this and definitely was still interested in the outcome ^^

If you want to further experiment, you should be able to do connection testing without the actual printer being attached, just with the board. At least connecting should work. Depending on the firmware that is on that board supporting it or not, there was also a dry-run command built into at least mainline Marlin that would allow to print without printing and that should unearth any communication issues. Alternatively you could try streaming a file to SD, if there are communication issues that definitely will also unveal them, maybe even more so than printing. Could you post a picture of the controller board?

Also, just as a heads-up, make sure you update the firmware on the silent board, I remember seeing some posts on here that indicated some issues with one axes stopping to move all of a sudden during a print that if I remember correctly got fixed for everyone trying so far by a firmware upgrade.

I had similar issues with ender 3 and pi3 and pi 4
Changed usb cables ,tried shielding ,two different pi 2.5amp power supplies and could not get consistent usb connections
What i found eventually was that the usb connector was not grounding properly and every now and again the usb would disconnect
Solved eventually by moving the pi off the same workbench surface and it worked for weeks with no issues with 3 hour prints
Since then i have updated to a 32 bit bigtree v2 motherboard and have not had an issue since
I think it came down to bad grounds on either usb connector on pi or ender3 motherboard

Well, this seems like some issues I have (had).
First: make sure ther is no +5V connected to both sides of the USB-cable (see other topics here): it can make really many strange communication-problems when the Pi is sometimes feeding the printers mainboard with power or the other way round. I normally just cut the 5V wire in the USB-cable but there are other ways of doing this.

Second: on some (!) printers I still have problems with communication and for sofar all are solved by simply making an 0 / ground connection besides the small one in the USB-cable directly between printer and Pi.

So, simply: a wire from one 0 on the printer's UPS to one 0 on the Pi's power-supply (or on the Pi itself).
This makes sure that they both have the same potential to ground and all differences in voltage are therefore levelled off and don't have to go over the USB-wires and therefore the signal is getting there much more stable.
Of course, if you use a grounded shielded cable with the shield connected to 0 on both sides (so, on the metal houses of the USB-connectors), you are doing the same thing.
But: not every printer has the houses of the USB connected to 0 and not every USB-cable has this shield connected on both sides.

Think of all cables like 'antennies' that will pick up signals (and voltages) from everywhere around.

By the way, always make sure the earth of your printer is connected to the case and to the earth of your socket. With a multimeter you can test this.

You probably have solved it with the other motherboard because that board has better grounding.

Here is a picture of the (old) mainboard. This is version 4.2.2.

The new mainboard (v4.2.7) looks very similar.

In theory I would like to do some more testing to be sure - but with a 5 month old baby in the house it's hard to find time to do projects! I'd also underestimated what a time sink this would be in general. 3D printing seemed like something where you would set it up and just print stuff but it's turning out to be a full blown hobby!

I have a bench power supply so maybe I can hook the mainboard up to that at the weekend and give it a go.

Also I have updated to the latest firmware too.

The sheath of the USB port is not connected in either the old v4.2.2 mainboard or the new v4.2.7 mainboard.

Regardless of whether the tin foil did anything or not, it is definitely some kind of a grounding issue. I'm just finding it hard to understand how the new mainboard fixed it considering the usb sheath is not connected on that either!