OctoPi WiFi/network connection troubleshooting megatopic

The only difference between yours and mine is I don't have a key_mgmt line (and I left the comments in):

## WPA/WPA2 secured
network={
  ssid="Morgan"
  psk="REDACTED"
}
country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

I reflashed a new Octopi image with your WPA Supplicant, Morgan. No dice (obviously changed the country code, and id/psk). Wlan0 still doesn't boot into the "up" status.

I'm doing a new reflash follow the procedure OutsourcedGuru has further up. Will also disconnect everything except power for the first boot with that and see if having something plugged it was causing some issue.

Update. I picked up another PI, 3B+ this time. Same issues. Wifi doesn't want to connect/even start in the "up" condition. But I am able to connect to octopi.local when I hooked Ethernet to the Pi, but the PI does not have access to the internet.

There is something unusual about your network configuration so we probably need more details about it. Start with details about your router(s) (wired and WiFi). Tell us about the system you are connecting to the RPi from. An "ipconfig /all" or an "ifconfig" from that system as well as an "ifconfig" and "iwconfig" from the RPi. What (if any) programs are running for anti-virus, ad blocking, etc.

I got my Octoprint working.

I ended up trying my mobile phone as a hotspot, and typed that into the Supplicant file, worked perfectly fine, like I'd have expected it to. Then I did Sudo apt update and updating everything. Installed the desktop, and then was able to connect to my local Wifi network through the desktop and it worked perfect.

Been hooked up and printing for a few hours.

Have been working on a pi3 wifi issue for a couple of days now with no luck and I am hoping somebody can give me a pointer as to what to try next:
Pi3 that has been working flawless for a couple years or more. I needed to change the SSID and password.My first go around was to change that in the octopi-wpa-supplicant.txt file.
Pi will boot just fine but will not connect to the network.
Burnt a new image, updated it and it works just fine.
Copied the octopi-wpa-supplicant.txt file from the working image SD card to the non-working SD card figuring I might have screwed something up with the editor - same result.
The octopi starts up and seems fully operational except that during startup it looks for the network (pauses) and then carries on without getting an IP. I can log into the pi at the prompt presented.
I seem to recall that the octopi-wpa-supplicant.txt file is only read once during the initial startup of the system but have read other posts that suggest it is being read every time .... if I change the octopi-wpa-supplicant.txt file, is it reloaded automatically or do I need to do something else?
Given that I can log into the pi, can I do anything to force connection to the network and once done can that be made permanent?
Again, same pi, one old SD card that was working for years and now longer connects, one new SD card with that same pi and it connects fine so I assume the issue is strictly with the SD card.

Some more info: I ran sudo raspi-config and tried >Network Options>wifi and got 'could not communicate with wpa_supplicant'
I am not sure if I have a permission problem and for that matter which file permissions need changing.
In any case, ifconfig shows that the wireless lan is not connected (no ip number listed)
iwconfig also shows that there is no wifi connection

Last update: issue has been resolved by messing around with the wpa_supplicant.conf file. I am pretty certain that I had replaced the file with the same file from the working SD card but who knows after so much messing around.
I suspect a non-printable character of some kind but I do not know for sure - I did not use any of the bizarre Windows or Mac editors that seem to feel they don't have to be bound to standards and customs that everyone else expects (yeah Linux)
All is well that ends well ....

Hi I had a very serious connection problem with 0.17.0 fresh install.

octopi-wpa-supplicant.txt file was correct, but didn't connect via wifi.
I connected with cable wifi scan showed the Wi-Fis around but octopi didn't connect. I restore a backup with:
OctoPrint version : 1.3.10
OctoPi version : 0.15.1
Everything is just ok so my raspberry pi, wifi dongle DS card were ok.
I tried fresh install because since I updated to 1.4.1 (from 1.4.0) i had several connection issues especially plugins weren't available because octopi was saying no internet connection.

I'm giving this information to investigate by developers.
I hope it can be helpful.

I finally signed up for an account to thank you. Nothing I had done had fixed my issue where I remove the network plug and the WiFi also goes away.

Putting the country code in front of the network string did it (I just edited the default config :frowning:). Thank you so much, I can finally move my printer away from my LAN network!!

1 Like

Can't Connect to my WiFi
My Pi's Wifi Works as far as I know, and I can SSH via Ethernet. When I run "sudo iwlist wlan0 scan", I get back "wlan0 Interface doesn't support scanning."

Any idea what causes this? I've tried everything in the wifi troubleshooting post.
My other devices connect to the WiFi and "octopi.local" opens when connected via Ethernet SSH which would have me beleive it's not my Micro SD.

Any advice appreciated.

erniemc

Octopi newbie here:

I have an issue where my 2 yr old octopi install would not update due to something else that could not be updated in raspbian itself or so. Was advised to flash v17.

Raspberry PI 3 B
Got a new sd card
Got v17
Flashed that.
Setup the ssid & password & country.
Could log on locally.
Tried to get the desktop loaded, so I could get the touch screen setup again.

Could not get the desktop installed. Etc.
Commands work, but when looking closely, during install there's constant fetch errors.
Which lead me to find out that the unit is probably not even on wifi.

http://octopi.local does not work

How do I test what is going?
How do I fix a brand new install?

Static IP ? so I can see & access it perhaps via IP?
( previously I had a fixed IP ... so I always used 192.168.0.x to find the printer )

Thank you.