OctoPi WiFi/network connection troubleshooting megatopic

Can I just point out, if you post this remove your wifi config and replace it with something that is not your password. Posting that on the public internet might not go so well.

The less you change in the file, the better chance we have of discovering errors. Just change the password (hopefully, your configuration has a password).

1 Like

Thanks so much for your help. I hope I have added what you need.
Pi 4 - 4gig running just Octopi image.
Octopi 0.18.0 trying the nightly got something to work. Using the stable release I had Errors everywhere.
macOS Big Sur 11.0.1
Wifi mesh router Eero - I am plugged into one of the satellites which makes me think it has something to do with the software not my hardware set up. When not hardwired I can't see it on my Router. I've tried 2 pi's and they show up with a Raspbian card so WiFi works on the Pi's.

This happened when I was trying to update and I refreshed the browser on that screen before it was done updating. From that point on this is the issue. I tried new download, flash, SD card, Raspberry Pi.

Supplicant file:

## WPA/WPA2 secured
network={
  ssid="myusername"
  psk="blahblahblah"
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

## WEP "secured"
##
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0
#}

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


pi@octopi:~ $ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.4.95  netmask 255.255.252.0  broadcast 192.168.7.255
        inet6 fe80::e62b:e262:76d2:3d4  prefixlen 64  scopeid 0x20<link>
        ether dc:a6:32:29:da:e7  txqueuelen 1000  (Ethernet)
        RX packets 613  bytes 142846 (139.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 220  bytes 34901 (34.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 22  bytes 3455 (3.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22  bytes 3455 (3.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether dc:a6:32:29:da:e8  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

pi@octopi:~ $ iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

lo        no wireless extensions.

System info:
browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.1 Safari/605.1.15
connectivity.connection_check: 8.8.8.8:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.1
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

By stable release do you mean 0.17.0?

The RPi 4 2GB (and, I believe, 4GB) has had a recent hardware revision that renders 0.17.0 unusable. I think this means that you are going to need 0.18.0 and probably the latest nightly. Your supplicant file looks correct. "ifconfig" shows the device wlan0 so I believe you have a kernel driver that works.

What does "sudo iwlist wlan0 scan" show?

Thanks for the reply! I will post the result later tonight when I get by the printer.
Talking about the issues the Pi 4 has makes me want to try and step back a release to what I was running before I tried to update. Everything was running fine for at least 6 months or so with this same set up.

I got mostly black screens but at the end I got this:

IE: Unknown: 050400030000
                    IE: Unknown: 0706555320010B1E
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C121860
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 0B0500002E0000
                    IE: Unknown: 42020000
                    IE: Unknown: 2D1A3C081FFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1608000400000000000000000000000000000000000000
                    IE: Unknown: 7F080400080000000040
                    IE: Unknown: DD090010180200001C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 28 - Address: 00:AB:48:CE:2E:08
                    Channel:157
                    Frequency:5.785 GHz
                    Quality=43/70  Signal level=-67 dBm
                    Encryption key:off
                    ESSID:""
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 50ms ago
                    IE: Unknown: 0000
                    IE: Unknown: 01088C129824B048606C
                    IE: Unknown: 03019D
                    IE: Unknown: 050400020000
                    IE: Unknown: 070C55532024081E640C1E95051E
                    IE: Unknown: 3B028000
                    IE: Unknown: 2D1AEF021BFFFF000000000000000000000100000000000000000000
                    IE: Unknown: 3D169D050400000000000000000000000000000000000000
                    IE: Unknown: 7F080400000200000040
                    IE: Unknown: BF0CB2398033FAFF0000FAFF0000
                    IE: Unknown: C005019B00FCFF
                    IE: Unknown: C304023C3C3C
                    IE: Unknown: DD1A00904C0408BF0CB2398033FAFF0000FAFF0000C005019B00FCFF
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: DD071422DB02000000

Then let's try "sudo iwlist wlan0 scan >iwlist.txt". Search the output for the SSID that you have in /boot/octopi-wpa-supplicant.txt. We don't need to see the whole output file unless you have questions about it.

For future reference, you could also type "screen -L" which will start a session. Type the commands you want to capture and when done, type "exit". The session's output is captured in the file screenlog.0. If there are multiple commands to capture, this is easier than adding >file.name (to the first) and >>file.name (to the rest) at the end of every command.

Hey guys! I have an issue with connecting my Raspberry Pi 4 to the network. My situation is as follows:

My RPI with Octoprint 0.17 was running fine for about half a year. No issues with it. I printed everything with it. Webcam works, SSH works, I even made some SMB shares to easily access my files.

Yesterday morning at around 3 AM, my pi suddenly lost connection to the network. I found this out from my network logs coming from my router/AP, nothing was printing at the time and my printer was turned off. Rebooting didn't work, even after leaving it off for an entire night.

Things I checked:

  • Used my laptop USB C adapter for power. No low-power messages seen. I have tested with my PC USB port as well, then I do get low-power messages. All troubleshooting has been on my laptop power supply.
  • Wifi signal strength is fine. Pi hasn't been moved, and other devices can connect fine at that location, I'm about 10m from the access point.
  • I'm connecting to 5GHz network. Changing to a 2.4 GHz network (by adding a second network to wpa-supplicant including id_str parameter) doesn't change anything.
  • I'm editing through the CLI on the pi itself (nano). (On the PC I use notepad++, but only used CLI for this issue)
  • My router cannot see the device, so it is really not connected
  • I cannot ping my router. Ping 192.168.1.1 response is: connect: Network is unreachable
  • Response of sudo ifconfig wlan0 is:
  • Response of sudo iwlist wlan0 scan is: here: https://imgur.com/d1uhknV (I could only attach one image as I'm a new member on this forum). BlokmeisterWIFI_5GHz is the wifi that I should be connecting to, which is visible.
  • I have just redone a complete install of Octoprint 0.18 RC1 (used 0.17 before) and got the exact same results

I really don't understand what is going on here. Can someone help me?

Update:
I just tried a new SD card, and I still have the same issue. I then tried a raspberry pi 3, and there it does work. Switching back to the pi 4, same issue. This is weird, since I have also tried inserting the original SD card into the Pi 3, and that didn't solve it. Very weird. Can it have something to do with my hardware in that case?

Update 2:
I tried it again on the Pi 4, then moved back to the Pi 3, and it doesn't connect anymore. I'm completely confused now.

hello, I already have used rpi 3b+, so I just used it in this octoprint setup.
first, I quck booted used micro 16gb sdcard with SD card Formatter. and burned octopi 0.17.0 via etcher.
after that, editted octopi-wpa-supplicant.txt with notepad++. below is all of uncommented lines.

/////

network={
ssid="difinitely correct ssid"
psk="difinitely correct psk"
}

country=KR # Korea, Republic of

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

/////

after this, I plugged sd card in rpi. but, my Fing app(android) does not display octopi...

after this, for verify, I formatted sd card again, and set raspbian OS, checked wifi conection and ssh prompt acess both work.

I think I checked all of wifi setup and troubleshooting document.. cant figure out what is wrong. please help me..!!

Not actually a solution solution, but a bypass, and it may highlight something inherently wrong somewhere with the distribution that the dev team should look at and fix.

I have gone through several hours and nights of troubleshooting over the course of six months. My old 3B+ pi + touch display setup worked fine on wifi for two years. But octoprint was out of date, could not be updated, and so I was forced to start fresh.

Kind of nightmare scenario for a newbie, given some complexities in the setup, command line, had to retrace display instructions ...

Despite following every detail in terms of how to edit the config file for wifi (not UK, US, correct ID, correct PW) it would not go on the network. Hours and days of taking the pi box apart, screen on/off, sd card in, out, starting over, ... reading this forum, other install guides, watching videos, dealing with a mis-recognized US keyboard, ... forced to quit. Unable to print. Trying again a month later. Rinse repeat. Always down the same rabbit hole and stuck without network connectivity.

Finally I had enough and just strung a long ethernet cable. Boom. Instantly it is on the network. Up and running. I go the desktop environment installed.
Clicking around in there:

Time zone: UK
Country: UK

How? Why?

Despite me doing the setup many times, following all the guides ... edit config always US, correct ID, correct PW.

So, now it works on ethernet, great. Fixed my printer. Got the filament moving.

Fast forward. Trying without ethernet? Nothing.

But at least I have a desktop environment, display, keyboard and mouse.
I can see ethernet is unplugged. I get a wifi symbol. Wifi networks are available. Pick the one it should be on. Enter password. OK.

So imo there's a bug or flaw somewhere, and the available instructions (old & new) don't allow to properly and efficiently troubleshoot it, if one is not versed in cli, raspbian, etc.

I know that this is a mega thread, but I ran into a similar issue recently with an Asus RT-AC87U.
My pi connects to a guest network and I needed to allow "intranet access". without that turned ON, I was getting the same timeout issues as some people here.asus-wifi-octopi

Many routers configure the guest network in such a way that each system is prevented from talking to other systems in the guest network and more importantly, are prevented from talking to systems in the local network.

Not exactly what you want for a 3D printer.

After a lot of time spent, i figured out that if a password have a "*" at the end of it it'll simply never work, i'vre tried the wpa conf file generator and also adding from raspi-config both option aren't able to pass throught this special character, since i've never seen this issue in any forum i'll just say it. special character can be escaped using the wpa config file generator or any meant but the star ('*') won't be and will simply return a connection refused error, like if the credential are wrong