OctoPi WiFi/network connection troubleshooting megatopic

I inadvertently reset my router and then had to reentere all my settings again. Which made most of network devices go offline and never reconnect. After lots of trouble shooting and reconnecting things one at a time the octopi wouldn't relearn the network. Turns out I had to enable tkip manually in the router along with aes(default). As soon as I did that most everything automatically reconnected.

Thanks in advance!

I am running on a Raspberry Pi 2 B:
OctoPrint version : 1.5.2
OctoPi version : 0.18.0

Successfully flashed the OS using Etcher on a Mac. Can get an IP address from Ethernet, but will not connect over WiFi. Using a Belkin dongle, which dmesg | more sees on boot:

[ 5.199032] usb 1-1.4: Product: Belkin USB Wireless Adaptor
[ 5.208096] usb 1-1.4: Manufacturer: Manufacturer Realtek
[ 5.217070] usb 1-1.4: SerialNumber: 00e04c000001
[ 5.328442] NET: Registered protocol family 10
[ 5.338444] Segment Routing with IPv6

I have octopi-wpa-supplicant configured per the FAQ:

WPA/WPA2 secured

network={
ssid="Metroplex"
psk="PASSWORD"
}

country=US # United States

The pi seems to "see" my router when I run sudo iwlist wlan0 scan:
Cell 09 - Address: 4C:8B:30:68:E8:0D
ESSID:"Metroplex"
Protocol:IEEE 802.11bgn
Mode:Master
Frequency:2.452 GHz (Channel 9)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:wpa_ie=dd1c0050f20101000050f20202000050f2040050f20201000050f2020c00
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra:rsn_ie=30180100000fac020200000fac04000fac020100000fac020c00
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD800050F204104A0001101044000102103B0001031047001061426D22C5067E7FDC660E1ACC392A771021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
Signal level=100/100

I'm stumped.

Thanks!

Micah

I have been having issues with upgrading network hardware and the octoprints not connecting to the new routers (even with the same ssid name and password (has an initial UPPER case letter (and other UPPER case letters at the end)) from my old tplink n router, and even with mesh routers, but suddenly after changing the INITIAL letter case of the SSID to lowercase ALL of my ocroprint pi's are connecting.
summary changed INITIAL char of SSID from upper case to lower case IN THE ROUTER, and now working, but INITIAL upper case SSID name (in router) not connecting

So I have my OctoPi working on a SSID. However, I want to change which SSID it is connecting to as a transition network setups(My old name is rather juvenile).

However, after using Nano (also tried Notepad++ on windows directly on the mSD) to change the SSID and password to the new network the Pi wont see or connect to it.

If, with making no change on the OctoPi, I turn back on the old SSID the Pi has no problems connecting.

The wpa-supplicant file is confirmed to be changed after a reboot but the Pi isn't connecting to any SSID but the old.

I am near tearing my hair out over this. Any advice?