Octoprint doesn't load at octoprint.local

I following the directions at:

I have also followed the directions on Octoprint's website. The following applies to both methods.

When I get to "Set Up Octoprint", I try to go to "Octoprint.local" but the window either never loads or takes me to a white screen "505 Internal Server Error".

I have researched and tried to figure this out and reinstalled the image multiple times to the flash drive but I can't get into the Raspberry Pi.

I am not very technical so if I need to provide something technical or do something technical, please provide the directions as I may not know how to get or achieve the end result.

I am trying to set up remote access/operation and set up the camera for remote monitoring.

What is the problem?

I followed How to control your 3D printer using OctoPrint and Raspberry Pi - Raspberry Pi exactly and when I try to view octoprint.local, I get a white screen that says "505 Internal Server Error" or the webpage just never loads.

What did you already try to solve it?

Researching articles and can't find a solution to this problem.

Have you tried running in safe mode?

No. Using a Mac and trying to access raspberry pi on wifi.

Did running in safe mode solve the problem?


Systeminfo Bundle

IDK how to do this. I am not very technical.

Additional information about your setup

Octoprint New camera stack
Raspberry Pi 4B with arducam module 3
Ender 3 S1 Pro
Mac OS 13.4 Safari and Chrome
Wifi 5GHZ

you can click the link that it generates here in the forum to find out how to get it.

this should be octopi.local if you didn't change the hostname in Raspberry Pi imager's advanced configuration section during flashing. If you did change the hostname then it would be <whatever host name you used>.local.

The default hostname in Raspberry Pi Imager is actually "raspberrypi" but I changed it to "octopi" which is what I'm trying. I typed it wrong in my post. I get the above errors when I go to octopi.local

I tried following:

But alas it doesn't say where I need to be to even start getting this information. I don't know how to access "Octoprint settings". I can't even access my raspberry pi so idk how I'd even get this information.

That means, the server is running, you have contact, but the server can not properly react to the browser request.

What browser are you using and did you try another one?

You can try to access via SSH:

Thank you that helps me start to understand what’s going on.

I have used safari and chrome. Cleared cache/cookies. Tried both browsers multiple times.

Following this link using the Mac directions:

When doing entering this step in Terminal:

Enter the SSH command followed by username@server. In the example below, our user was “pi” and the hostname was “raspberrypi.local”

I get:

kex_exchange_identification: read: Connection reset by peer

Followed by a long series of digits and "port 22"

Terminal goes back to the default "username" beginning. Does nothing else.

In this topic the hostname has been reported to be octoprint.local, octopi.local, and raspberrypi.local.

The Raspberry Pi Imager allows for the setting of the hostname, the username, the password as well as enabling SSH, the WiFi credentials, and other settings.

You don't have to be very technical but you do have to be very accurate when you provide us with details. Without accurate information, we can't provide accurate help. Please provide the version number of the RPi imager, the values you specified in each of the settings fields (except the passwords). If you aren't sure, please re-image the microSD card again so we both know exactly what was done.

After booting the Raspberry Pi with this fresh image, attempt to connect with SSH. Please provide a screenshot of this attempt so we can see exactly what you did and the exact error message.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.