Octoprint Failed to write to serial port on Ender 3 Max Neo

Hi everyone, I am new here and new to 3d printing. So far, I have done the bench boat, the XYZ cube, and a trash can for all my failed PLA to go into =D. By day I'm a retired IT professional in the cloud computing, DevOps arena and am fluent in Linux =D. So I'm not afraid to get my hands dirty.

I have the latest octopi installed. I have an Ender 3 Max Neo.

What is the problem?

As the title suggests, octoprint is installed. DNS works, and everything is fine, except it cannot talk to my printer.

The error message says it failed to write to the serial port.

What did you already try to solve it?

I looked at tons of YT vids for answers. I have checked the known issues w/regards to the USB powering thingy. The Ender 3 Max is not listed as having this issue (however, I will be buying a Power Blocker Dongle here today ... just in case.) So far I have found zero online references to people w/the ender 3 max having issues with serial connections over USB. I saw where this one guy opted to install some henky-looking USB drivers to solve some issues related to usbserial connections. That didn't work for me, either. I eventually deleted the octopi install and reinstalled the OS for a clean install.

I have also run upgrades to the os software (using apt).

Have you tried running in safe mode?

What is safe mode? Is the printer in safe mode? Or the pi? I'm confused.

Did running in safe mode solve the problem?

Obviously not.

Systeminfo Bundle

serial.log:

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 4 port/baudrate candidates: /dev/ttyS0@115200, /dev/ttyS0@250000, /dev/ttyAMA0@115200, /dev/ttyAMA0@250000
Trying port /dev/ttyS0, baudrate 115200
Connecting to port /dev/ttyS0, baudrate 115200
Could not open port /dev/ttyS0, baudrate 115200, skipping
Trying port /dev/ttyS0, baudrate 250000
Connecting to port /dev/ttyS0, baudrate 250000
Could not open port /dev/ttyS0, baudrate 250000, skipping
Trying port /dev/ttyAMA0, baudrate 115200
Connecting to port /dev/ttyAMA0, baudrate 115200
Handshake attempt #1 with timeout 2.0s
Could not write anything to the serial port in 5 tries, something appears to be wrong with the printer communication
Changing monitoring state from "Detecting serial connection" to "Offline after error"
Closing down send loop

Additional information about your setup

Used the latest stable Octopi installed via the raspberry pi imager.

SOLVED

and no sooner had i written this, i found yet another USB cable to try (this is like my 10th usb cable by the way) and whala! it worked lol.

1 Like

Hello @phreekbird !

Blue words are links and give you more information.

And please share the systeminfo bundle.

The snippet is not the serial log, these are some lines from the OctoPrint terminal.

For you are using a Creality mashine:

Please try with/without a SD card in the printer's SD card slot.

Also try this: