Octoprint hits bed with nozzle

What is the problem?

After successfully printing something when I try to move y axis, octoprint moves z axis all the way down until it hits the bed. Octoprint also ignores y axis limit switch. After that my printers z-level is sometimes all over the place

What did you already try to solve it?

I don't even know where to start, but i had to reset my printer twice because z level was all over the place because of octoprint.

Have you tried running in safe mode?

Had the problem since start with no plugins installed but I'm gonna try tomorrow

Systeminfo Bundle

octoprint-systeminfo-20211007212929.zip (44 Bytes)

Additional information about your setup

Running on a Raspberry Pi 3b+, Printer is Crealtiy Cr 10 v3 with BlTouch

Do you have an SD card in the slot in the printer? Try putting one in:

2 Likes

I'm going to check tomorrow. Thank you :slightly_smiling_face:

Now I've put an SD-Card in it and end stops are still sometimes ignored. Also i have some very weird behaviour, after octoprint finished, I tried to move the bed y, however octoprint then starts to move z down with the nozzle without using bltouch until it hits the bed. Following commands showed up in the terminal. Is this a bug?
Send: G91
Recv: ok
Send: G0 Y-1 F6000
Recv: ok
Send: G90
Recv: ok

Not an OctoPrint bug, at least. It is Creality firmware, and we do know there's a number of bugs in those builds.

If OctoPrint only sends G0 Y-1 F6000 then the only axis moving here is Y. If the printer then moves Z as well... It is broken

2 Likes

New firmware seems like it might be a good option for you. Marlin is not hard to build once you get the environment setup. Guides etc. across the internet are your friend, take it slow as it can be a tricky process.

2 Likes