Octoprint keeps disconnecting from printer

What is the problem?

I've installed Octoprint on a Raspberry Pi 3B and it's connected to my Artillery Sidewinder X2 using the USB interface. At first for shorter prints (<2h) the setup is working properly but recently with any longer prints I run the risk of Octoprint disconnecting from the printer. The problem is similar to this post, but it doesn't look like it was resolved.

Octopi Keeps Disconnecting

What did you already try to solve it?

  1. Tried changing USB Cable
  2. Tried moving the pi and printer to their own circuit
  3. Tried taping off the 5V line in the USB Cable

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Have not tried running in safemode

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230824200530.zip (449.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version 1.9.2
OctoPi Build 2023.07.18.111854, based on OctoPi 1.0.0, running on Raspberry Pi 3 Model B Rev 1.2
Printer Artillery Sidewinder X2
Browser - Firefox
OS Windows 10, Android, iOS

Its likely some kind of interference. Could be power related but your log does not seem to show anything on that.

Turn on the serial.log and send that so we can see what it received. That said, it is not likely to really help, most of these issues are cable/noise related.

Some other general things to consider... All found in many other posts.. also not an exhaustive list on the topic.

Are you using a good quality cable?
Is the cable as short as it can be?
Is the cable shielded?
Does the cable running past the servo cables? Does it have a ferrite bead on it? (I have never needed this one but some say it has fixed their issues.)

There is also a featured post that is directly related but easy to miss.
Are you blocking the power line form the printer to the Pi? There are multiple ways to solve this.
This thread has a number of them listed.. From the quick and risky to the costly and unnecessary. Also a few in the middle ground.

Thanks, I've turned the serial.log on now. I'll post it when I print something and it populates the log.

I have done a few things so far that have seemed to stabilized it:

  1. Using stock cable that came with the printer seems to connect better at the port.
  2. Stock cable that came with the printer is only 20cm long, so plenty short.
  3. Stock cable is shielded
  4. No servo cables, nor does it have a ferrite bead.
  5. 5V pin has been taped off
  6. Dropped baud rate by half - from 25000 to 12500

Ran prints all night with it yesterday and seemed to have minimal issues. Will keep monitoring the situation.

1 Like

Here's my output from serial.log. I don't see anything in particular that would warrant a disconnect error.

Also to report that error hasn't happened since my last actions.
serial.log (3.7 MB)

1 Like

Final Update:

It looks like the USB cable was the culprit - for anyone else having this problem, please remember to buy cables according to the below criteria:

  1. Fits snugly in the printer port (good connection)
  2. As Short as possible
  3. Shielded
  4. With Ferrite Core (can't hurt)
  5. 5V pin taped off
  6. No interference along the cable
  7. Drop the baud rate by half IF the above doesn't resolve.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.