Octoprint keeps disconnecting mid print

What is the problem?

Octoprint keeps disconnecting during the middle of prints. I have removed all plugins, done resets, I've tried everything and I cannot figure out why this is happening

What did you already try to solve it?

Uninstall plugins, change USB to printer, switch to LAN from WiFi, fresh install, new Pi with more RAM

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Only works in safemode

Systeminfo Bundle

octoprint-systeminfo-20240522201416.zip (75.4 KB)


Additional information about your setup

octoprint.log (281.5 KB)

Obico is overloading the system:

2024-05-22 17:42:05,786 - octoprint.plugins.obico - ERROR - datachannel payload too big (5584)
2024-05-22 17:42:06,546 - octoprint.plugins.obico - ERROR - datachannel payload too big (5585)
2024-05-22 17:42:07,308 - octoprint.plugins.obico - ERROR - datachannel payload too big (5584)
2024-05-22 17:42:07,733 - octoprint.util.comm - ERROR - Unexpected error while reading from serial port
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/comm.py", line 4172, in _readline
    ret = self._serial.readline()
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/comm.py", line 6931, in readline
    c = self.read(1)
  File "/home/pi/oprint/lib/python3.9/site-packages/serial/serialposix.py", line 595, in read
    raise SerialException(
serial.serialutil.SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

and/or another one of the 3rd party plugins.

What printer do you have?

Ender 3 Pro on a 4.2.7 board. I have uninstalled Obico and it happened again. Here's the most recent log.
octoprint (1).log (303.7 KB)

I never had an issue before. I just moved apartments and since I moved this has been happening non stop.

Have you tried wit/without SD card in the printer's SD card slot?

You may also try this:

Also try different USB cables.

Check if the USB connectors are proper attached to the PCBs

If it works in safe mode, then it is one of the plugins.

There's no SD in my printer. I am going to try a brand new USB and see if that works. I even tried installing OctoPrint on another machine (Windows Laptop running Ubuntu) and the same thing happened.