Octoprint lost wifi connection

Hello,

I ask your help because my Raspberry PI4 Wifi network connection is unstable and I frequently lose the connection to Octoprint PC interface (http://octopi.local/#control).

However when i'm connected, my gcode downloads well and my 3D print continue to the completed end (even if I lose the PC to octoprint connection during printing).

So my only problem it's i can't to have a stable connection from my PC to http: //octopi.local/#control.

To resolve that, My CR10S pro still on, I need to turn off Raspberry power and disconnect serial cable to the printer. Then I power on supply of the raspberry and I reconnect the serial cable to the printer and I can reconnect to the interface http: //octopi.local/#control

To resolve that I tried to change several time serial cable / Closer the rasberry to my wifi box / Upgrade all software / Always Edit the octopi-wpa-supplicant.txt file with NotePad++

I'm not a specialist but my log file has line like this:

2020-11-14 11:33:41,493 - octoprint.util.comm - WARNING - | Þ^AaQam^eì.(¼øj¨]pš% Yÿ6áM0ÌÙZ62X6Ù·H¹XñhJB@ÔaJ aA“p|râ^/á3’™*:HJ JA‚!ˆKr¢Ü5î:8^/›^CaHlùEFÙJ áA%9A÷%9Aó%hH”xñz &2M.a™>H6ÙÑ8|BÂÁAÿˆ’JÿŽþ%9QïKBˆrñZ\x00é+þM@™ÙÑÀœl3.a–nBâ_é«È–^Có.at|BÒaKr¢ä%!È%9Ap|rÂv6a,=áo>?nÃ5aÛc6O6‹]‹6eî]5oÀñhJÿJB’$yQŽLAfñ\}p«m2'˜j ’$yQŽ]pøee]2aJ ¢@qI8|BÒQ}JBèŸJ@ñhzÂfTJ8|BÒq}†Jb’¬ˆrLhzÂA0†’º*aJq}JBêè%PøJq}Ô½þ8|BÒq}IA²$PøJq}†%IA=*aJq}†%jbJ2aJQ}jÍý8|BÒq}”NA}*:šJ¡hñH´J2'šJ†$§%p|BÒQ}†JBÈ¿’PøJq}”NA}

Thanks for your precious help :wink:

Hardware configuration :
PC on Windows 10
Raspberry PI 4 (with Rasberry 5v 3000mA power supply)
CR10S Pro 3D printer V1 with BLboutch

Software configuration:
I Edit the octopi-wpa-supplicant.txt file with NotePad++
Raspberry connected by wifi
CR10S Pro firmware: TM3D 10S Pro (Marlin 2.0.5_DW6.1 TM3D SSMDBB)
Octoprint v1.4.2

octoprint (1).log (546.3 KB)

Try this :slight_smile:

Thanks @PrintedWeezl,

I'll try and keep you informed :wink:

Best regards,
Tony

I didn't see this the first time around, but I would suggest also looking at devices that might produce EMI or some other kind of interference. The log line indicates significant data corruption going on in the serial connection.

In addition, I cannot see a single shutdown event in your logs. Do not just pull power from the Pi. This can corrupt the SD card, causing it to not work properly. Always use the UI menu to shutdown system, wait for the lights to stop flashing on the Pi before turning it off. Raspberry Pi is just like any other computer, it requires graceful shutdown, not just pulling power.

This can cause corruption in just about any part of the system, and it means that the wifi connection dropouts may be as a result of this. To fix corruption, you have to re-image the SD card again.

Devices like fridges, microwaves, washing machines etc. which all run quite high power and/or with strong motors can cause significant interference problems. I use a cabled connection with one of my Pis since the connection kept dropping in that place, sometimes the signal is just not strong enough. I suggest as well, that you use the Wifi Status plugin to track if it is getting a good signal.

I'll add one more thing to check (as it came up recently)...

Make sure all the covers are on the printer electronics.

1 Like

Hi all,

First, thanks for your help. :wink:

For your information, below what i have trided:

  • I put tape on 5V pin USB cable.
  • I turn off Cura during printing (to avoid any communication interferences during printing)
  • I install Wifi Status plugin (the most bad signal when door is closed is 76%) => Pict in attached
  • I reinstall Octoprint on my SD card
  • All covers are on printer

But same result, I frequently lose the connection to Octoprint PC interface ([http://octopi.local/)... :upside_down_face:

I just lost my connexion now (Without even being in printing - Printer is only turned on)

I tried to just restart Raspberry PI4, but connexion isn't OK.
I tried to restart Raspberry PI4 and disconnect USB cable and reconnect it and connexion came back ok.

Please find logfile:

octoprint.log (301.7 KB)

Are we talking now about the network connection or the connection from OctoPrint to the printer?

Try if using the IP address (or an internal name resolved by your router) instead of that .local domain is more stable for you. I've seen some issues with that multicase DNS stuff in the past, so I wouldn't be surprised if this was the cause of your troubles here.

1 Like

I use the IP address instead of http://octopi.local/
And now I can re-acess of Octoprint interface without restart my raspberry.
It seems to be the solution ! :slight_smile:

Thanks again for your help, I will keep you informed :wink:

Connexion Octoprint interface problem is solve => I must use IP address instead of http://octopi.local/
Thanks again all for your help :wink:

1 Like

Hello I'm new to Octopi however I am having this issue were my wifi keeps disconnecting ever 5-10 mins these are my logs octoprint.log (447.9 KB) I would really appreciate anyone's help
I am using the IP to login and not the local. I also connected the wifi plug in and it shows no wifi