Octoprint no serial port found

What is the problem?

octoprint no serial port found. printer also wont connect to laptop

What did you already try to solve it?

I have tried different cables as well as the 5 pin mod.

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20240109164049.zip (47.4 KB)

Additional information about your setup

latest octoprint version, raspberry pi zero 2, ender 3 neo

Hello @Olive_goo !

So it is a printer issue.

As last resort and because it s a Creality printer, you may try this:

Also try it with and without an fat32 formated sd card inserted into your printer.
I know it sounds weird but it helped in some cases.

1 Like

just tried this and also the tape mod, neither worked :frowning:

But the printer itself runs fine?

yes
however it wont connect to cura via the usb cable

How many?

There are a lot of charge-only cables around.

A good cable is quite thick and has ferrite beads at the ends.

i have tried 3 cables i think they are data but idk

i also have to use a usb to microusb adaptor because i could not get a microusb to microusb cord

BTW: What USB port did you use on the Pi 2?

The outer side is power in only.

i just tried both and neither worked

Since it does not connect to Cura from your PC and it doesn't connect to OctoPrint from the Pi. I would suggest that you make sure you know your cable is a data cable before you waste time trying other things. Also the adapter you are using. Make sure that is data capable too.

For clarification: What kind of USB connector has the Ender 3 neo?

it is micro usb

I slowly come to the conclusion that the USB port on the printer is broken.

no im stupid, just bought a data cable and it works fine

2 Likes

this is what I use for the pi power printer issue $1.52:

We are talking about data cables, not power cables.

You do realize you can use this to turn off the power to printer so the pi is not powering it...?
Sorry, just getting a little ahead of myself.