Octoprint not booting with connected printer via USB

What is the problem?

I have a printer with an Makerbase MKS SGEN-L V2.0-board. Its working since a year or more. I have set it up with a new Display, MKS 12864 Mini V3.0, also equipped with an SD-Reader.
When starting The Raspberry Pi 3, it is not working. The flashing light stops and it hangs. It boots when i unplug the USB-connection to the mainboard.
The boot works when i disable the SD-Card-Reader on the display.

What did you already try to solve it?

I tried to alter some settings inside the Marlin-Firmware, its a Marlin Bugfix-Version.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 917016576
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.2.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

octoprint-systeminfo-20210912134843.zip (109.3 KB)

Will try the following:
I will try to create a firmware using the release-version of Marlin 2.0.
I could not use my old version cause the display was not included.
Perhaps this helps.

In my opinion, the SD-Card connected via USB is blocking the Boot, looks as it tries to boot from the SD-card inside the display.

Please do it first.
There are at least 3 plugins that are incompatible to your installation.

Also the display panel plugin is making trouble.

You could also try this one:

Could the printer be drawing too much power from the Pi, resulting in it crashing?

I have tried this, but i am not sure if i can start Opctopi in Safe Mode the way i need it... The problem only occurs when starting The Pi and the printer by switching them on at the same time.
It also happens when starting the Pi with printer switchedoff power source, cause the Printer gets its 5V via USB.
The pi does not boot until i disconnect the USB, and before doing so there is no Wifi-Access.

That is the reason what @Charlie_Powell recommended.

This happens when i use the LCD-SD-Card in fimware-configuration. It starts OK when i configure the Mainboards SD-Card-slot.

The Printer ist not taking power from the Pi. The board has a big powersource, their mains are in the same current-loop, the same power socket. As mentioned in the last post, this only happens when using the LCD-SD-card-slot, it does not happen when using the internal sd-card.