Octoprint not connecting to printer

What is the problem?

After having to disconnect my printer from my pi to remove a filament jam octoprint is not connecting to the printer it shows "No more candidates to test, and no working port/baudrate combination detected."

What did you already try to solve it?

Removed all plugs and power cables from printer and pi for 5+ minutes then reconnected cables and turned pi and printer. Tried restarting octoprint from browser and using putty as well and still not connnecting.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

octoprint-systeminfo-20210721014011.zip (26.6 KB)

Additional information about your setup

OctoPrint version 1.6.1, OctoPi version 0.18.0 running on Raspberry Pi 4 Model B, printer Prusa Mini+, firmware 4.3.1, browser Opera, operating system Windows 10, SSH Putty

edited post to have bundle

Seems like the USB/serial simply isn't being found.

Try this:

  1. Connect to OctoPi via SSH
  2. Disconnect the printer USB cable.
  3. Execute dmesg -w over SSH and press Enter a few times to add some blank lines.
  4. Plug in the USB cable from the printer. You should see some output afterwards. Paste that here. If you don't see anything then the Pi isn't detecting your printer at all. Check connections, swap USB cables, try different USB ports, try another USB device and see if any output is generated.

So the serial device should be /dev/ttyACM0. OctoPrint still won't connect?

Unfortunately OctoPrint still won't connect still shows "No more candidates to test, and no working port/baudrate combination detected." I tried all the ports on the pi same thing. Unfortunately I don't have another usb to micro-usb cable right now to test with.

Oh whoops the last line was cut off for me on my mobile. It's saying that the USB disconnected after initially seeing it.

Might be worth trying from another computer with something like Ponterface

the next line had nothing to do with it, I tried doing ctrl+c to copy when I was trying to get the info. The last line that came up after plugging the printer back in was the usb 1-1.2: USB disconnect, device number 6. I don't have another computer to use.

Just got a new usb to micro usb cable to try and now it's connecting. Guess there was a sharp bend that must have kinked the first cable now I have a more flexible one.

1 Like

i have the same problem and this is all it gave me:

I am having the same problem, but with different output in the SSH (below) can anyone assist further?

[ 4204.704490] usb 1-1.1.3: new full-speed USB device number 7 using dwc_otg

[ 4204.838139] usb 1-1.1.3: New USB device found, idVendor=1d50, idProduct=6029, bcdDevice= 1.00

[ 4204.838156] usb 1-1.1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[ 4204.838170] usb 1-1.1.3: Product: Marlin USB Device

[ 4204.838184] usb 1-1.1.3: Manufacturer: marlinfw.org

[ 4204.838197] usb 1-1.1.3: SerialNumber: 11FF500BAF3D1C805C9747F3F50020C7

[ 4204.839434] cdc_acm 1-1.1.3:1.0: ttyACM0: USB ACM device

[ 4204.840781] usb-storage 1-1.1.3:1.2: USB Mass Storage device detected

[ 4204.855139] scsi host0: usb-storage 1-1.1.3:1.2

[ 4205.866985] scsi 0:0:0:0: Direct-Access Marlin SDCard 01 1.0 PQ: 0 ANSI: 0 CCS

[ 4205.867747] sd 0:0:0:0: Attached scsi generic sg0 type 0

[ 4205.868591] sd 0:0:0:0: [sda] 245760 512-byte logical blocks: (126 MB/120 MiB)

[ 4205.870687] sd 0:0:0:0: [sda] Write Protect is off

[ 4205.870707] sd 0:0:0:0: [sda] Mode Sense: 00 00 00 00

[ 4205.873389] sd 0:0:0:0: [sda] Asking for cache data failed

[ 4205.873410] sd 0:0:0:0: [sda] Assuming drive cache: write through

[ 4205.921698] sda: sda1

[ 4205.929928] sd 0:0:0:0: [sda] Attached SCSI removable disk