Octoprint server does not start after error while adding and updating plugins and octoprint

What is the problem?

after installing OctoPrint-MarlinSlider and updating plugins plus upgrading from 1.8.3 to 1.9.0 i got an error. i tried to restart octoprint with the still running webinterface and it never came back to life. rebooting did not help. i always get the infamous: The OctoPrint server is currently not running


plugin_softwareupdate_console.log from that day:

What did you already try to solve it?

via SSH:
ps -ef | grep -i octoprint | grep -i python
-> no output at all

i tried apt update & upgrade
-> nothing changed

i tried:
/home/pi/oprint/bin/octoprint serve
this is the result:
2023-05-25 00:12:47,389 - octoprint.startup - CRITICAL - Could not initialize settings manager: cannot import name dataclass_transform
2023-05-25 00:12:47,389 - octoprint.startup - CRITICAL - There was a fatal error starting up OctoPrint.
Could not initialize settings manager: cannot import name dataclass_transform
There was a fatal error starting up OctoPrint.

tried safemode, but i am not sure if it worked - didnt start the server

card seems to have enough free space too...
Filesystem Size Used Avail Use% Mounted on
/dev/root 32G 7.9G 22G 27% /
devtmpfs 786M 0 786M 0% /dev
tmpfs 955M 0 955M 0% /dev/shm
tmpfs 955M 8.9M 946M 1% /run
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 955M 0 955M 0% /sys/fs/cgroup
/dev/mmcblk0p1 265M 51M 214M 20% /boot
tmpfs 191M 0 191M 0% /run/user/1000

from now on, i have no clue but to go for complete wipe. before i do this, i would appreciate any further directions :slight_smile:

Have you tried running in safe mode?

yes, enabled in config.yaml - not sure if it worked tho

Did running in safe mode solve the problem?

no change

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

well, no webinterface and SSH didnt help either, just 'command not found', sorry
is there an other way to get it?

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.9.0
OctoPi version : 0.17.0
Anycubic I3 Mega
Google Chrome

I cannot access google drive, can you attach the logs to the post directly please?

i hope it works, lets see...

octoprint.log (28.9 KB)

plugin_softwareupdate_console.log (60.4 KB)

You seem to have run into yet another permutation of pip dependancy errors with plugins.

Octolapse seems to be causing the failure.

Short of rebuilding from scratch, you can try to remove it and see if you get past the pint of failure. There is no commandline option for this that I am aware of, I might be mistaken, some other members might have more experience in this area.

Another option is to use a shell script to remove them, fist step is to see if you can find any:

find /home -name '*octoprint_octolapse*' -exec ls -lR --color {} \;

Share the output and I can try and help you to remove it with another script.

didnt think octolapse can crash the entire server... from my understanding, it is an addon, right? is there a way to boot without that one? read something about safe-mode. i tried to boot safemode, but i am not sure, if it worked... or is it crashing way before even considering safemode?

anyway, the FIND had quiet some output. i put it in a file:

also, thank you alot for your help! :slight_smile:

output.log (43.9 KB)

I think it is a combination of things, but octolapse is just the first fatal issue in the queue.

Safe mode is a good idea, I think try that first.

/home/pi/oprint/bin/python /home/pi/oprint/bin/octoprint safemode

then follow up with:

sudo systemctl restart octoprint

then check the logs again.

tail -100 /home/pi/.octoprint/logs/octoprint.log


cat /home/pi/.octoprint/logs/octoprint.log |more

hmm, first line throwssome import error...

Traceback (most recent call last):
  File "/home/pi/oprint/bin/octoprint", line 8, in <module>
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/__init__.py", line 1008, in main
    octo(args=args, prog_name="octoprint", auto_envvar_prefix="OCTOPRINT")
  File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1130, in __call__
    return self.main(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1055, in main
    rv = self.invoke(ctx)
  File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1657, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1404, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 760, in invoke
    return __callback(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/click/decorators.py", line 26, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/server.py", line 273, in enable_safemode
    overlays=get_ctx_obj_option(ctx, "overlays", None),
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/__init__.py", line 203, in init_settings
    from octoprint.settings import InvalidSettings, settings
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/settings/__init__.py", line 35, in <module>
    from octoprint.schema.config import Config
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/schema/__init__.py", line 4, in <module>
    from pydantic import BaseModel as PydanticBaseModel
  File "pydantic/__init__.py", line 2, in init pydantic.__init__
  File "pydantic/dataclasses.py", line 41, in init pydantic.dataclasses
    # +---------+-----------------------------------------+
ImportError: cannot import name dataclass_transform

and it refuses to boot. doesn't even generate any new log entries. the los is still the same as yesterday.

at this point, i think about wiping that thing and importing the data and statistics i want to keep/reimplant... no log, no info, no safemode.... i think it is dead for real? still wondering, what exactly killed it! :headstone: :skull_and_crossbones:

The easiest path is a new octopi image, they are very reliable and stable.

I'm new at this community, thanks for the support!

I have the exact same Issue described here. Upgrade to v1.9 and then my system stop booting. Can't restart via SSH and no clear error is shown on the log file. I've installed v1.8 with my new printer a week ago!

My log is attached.
Octoprint.log (10.4 KB)

Any chance to avoid reinstalling?

Thank you!!

Hello @adyannu !

Please always share the systeminfo bundle. It contains other logs for more information.
BTW: This octoprint.log is crippled. Should be more.

You have an untervoltage and throttling issue with your Pi:

2023-05-25 14:42:38,559 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.
|      throttle_state: '0x50005'

See here:

As long this untervoltage is not fixed, a new installation makes no sense at all.

Hi Adyannu,

please include the system info bundle too.


As I already said :face_with_raised_eyebrow:

Sorry, didnt see that, was drafting while you posted ! :face_with_open_eyes_and_hand_over_mouth:

Hi @jattie.

I can't access the web interface and I ran octoprint systeminfo. but got no output. I'm sorry :confused:

This is muy full log file:
octoprint.log (17.2 KB)

Version 1.8 was installed and running for +7 days almost non-stop without issues until I ran the upgrade. I'll try with another PSU but maybe this issue (also reported by another user) is not related to undervoltage.

Can you please, as @jattie and I said, share the systeminfo bundle. The octoprint.log does not contain updaing prodedure data.

I tried to generate it via SSH but nothing happens, no file is generated.

Recovery page and web interface are both down, can't download the bundle. Can you guide me how to get the Systeminfo bundle in this condition so I can share it with you?

That's bad.

Where you found the octoprint.log, there are also other logs.

Please share the last two plugin_pluginmanager_console.log.

a forced reinstall might help, maybe not. but the steps would be to SSH to the pi and run these commands for your setup @adyannu

source /home/admin/oprint/bin/activate
pip install --force-reinstall --no-cache-dir octoprint
sudo service octoprint restart

I have only one and it is empty: 0 bytes.

But here is the plugin_softwareupdate_console.log with details from the upgrade.
plugin_softwareupdate_console.log (27.4 KB)

Any other from the list?

@jneilliii I have tried this and it worked for me!

I have my OctoPi up & running again. Thank you all for the support!!