Octoprint stop working after reboot

What is the problem?

After reboot Octoprint or power off the Raspberry (mine is a PI 3B+), Octoprint didn't restart. Some seconds after power on the Raspberry, I can see its IP in my Network, but after a short time, it disappears. It seems that it starts the boot system, but can't go on.

What did you already try to solve it?

I tried turn off and turn on the Raspberry, but not working. The only solution for me until now is flashing again the firmware. But it is so annoying, because I need to format the SD card, reinstall the Octoprint and re-configure over and over again. I would like to know a solution that is no need more reinstall the system.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint 0.17.0, OctoPi 0.17.0, Ender 3 Pro, Marlin, Google Chrome, Windows 10. Pi 3B+ is connected by ethernet cable to my Asus Router.

Hello @Calebe_Gomes!

Do you access via LAN or WiFi?
Maybe it's just a Wifi issue.

There is no need to format the SD card. Just flsh OctoPi on it and you are good to go.
Maybe edit your WiFi parameters.

Hello @Ewald_Ikemann!
I am connected via LAN, not WiFi. I just have flashed again the OctoPi. I can try reboot and see if the same error occurs.

Try it without a connected printer.
I guess it's a power related problem.


@PrintedWeezl, good idea! I will try this. Thanks!!

@PrintedWeezl it worked!! :grinning: I reboot and after shutdown the system without connected printer. I have to remember do it every time I shutdown and power off the Pi. Or print a object I watched in a Youtube that isolates Ground and V pins from USB plug. Thank you guys for this help!

You could also turn your printer on before turning your pi on

PS: I also made a guide :wink:

@PrintedWeezl thank you again for your guide. I will do this. But I had this same issue and this time I turn on the Pi without printer, camera even a fan that I connected into GPIO. Do you think I need flashing again the firmware?

It's possible that those hard reboots damaged the file system - in that case reflashing the image would help.
Which psu are you using for your pi? An insuffuficient psu could also cause this kind of problems.

Ok. I will reflash it. I am using the power supply that came with the Pi when I bought it. This spec is 5V 2.5A. Maybe it is better change this PSU for another or connect to my printer PSU using a step down module. What do you think?

If your psu is really the problem it would help.
You could check your octoprint.log s for undervoltage warnings. :slight_smile:

1 Like