OctoPrint with Octodash disappointing so far

I have a RPi 3B+ with the latest OctoPrint and Octodash, on a 7" touch screen, connected to a self-made printer with RAMPS 1.4 and Marlin 2.xx.

After finally getting OctoPrint and Octodash to run I connected them to the printer. The results are very disappointing, to say the leat.

There is a long delay between the RPi and the printer.

For example, when I try to look at the files on the SD card, that is in the Graphic LCD, it takes a while for it to upload to OctoDash. Once it finally uploaded it shows the name very truncated even though there is enough room for many more letters.

When I tried to shut down the print, I didn't like what how it was printing, it didn't shut it down. I had to stop the print through the Graphic LCD. Once I did this Octodash said that the socket was disconnected, or something like this. I had to restart the RPi since Octodash didn't control the motors anymore but showed the correct bed and extruder temps.

When I connect the printer to my PC and use PronterFace I don't have any of these problems and the connection is almost instantaneous.

Is there some settings that I can/have to change?

1 Like

OctoPrint reading the files from the printer's SD card can be a confusing and limited system. For a long time, the only way that the printer's files could be read is with the 8.3 format, for example as 3DBENCH~.GCO, instead of the actual filename 3DBenchy.gcode.

Enabling this option in the firmware should allow OctoPrint to request the long file names:

It will send M20 L if it is detected as supported.

How were you trying to stop the print? I assume through OctoDash? Does the same issue happen if you cancel it through OctoPrint?

I will try the Marlin firmware change and will see how it works.

As for stopping through OctoPrint, I can't/don't know how to do that since I'm using the 7" touch screen and not a computer and I have no idea how to start OctoPrint from the command prompt. So, yes, I tried to stop the print through Octodash.

You must have opened OctoPrint's web UI on another device at some point? Even just to set it up, going through the wizard.

OctoDash does not fully replace the core UI, it works alongside it with the main UI accessible in a web browser. This is how you cancel through OctoPrint, and it is necessary to isolate the problem and figure out what part of the setup is having an issue.

Yes, I did. I just didn't/don't want it connected to a PC as a permanent thing.

I hoped that that would not be necessary since it's a PITA, in my case, to do it. I'll look into it and try to hook it up to a PC.

Usual operation for OctoPrint would be accessed wirelessly through the browser, when the devices are both connected to the same network (WiFi or wired ethernet).

I'm confused. Where do you do your slicing and how do you get the resultant gcode to the printer?

I slice on my Windows desktop PC and transfer the gcode to OctoPrint using a browser on that Windows desktop. The printer is in another room so I go there and can use OctoDash to prepare the printer for printing and then start the print.

Alternatively, I can prepare the printer for printing first (using OctoDash) and then return to my desktop where I can slice, upload, start, and monitor the print(s) from my desktop's browser.

If I want to watch TV instead (yet another room), I can use my cell phone or a tablet to monitor the printer using a browser. If necessary, I can stop the print remotely if something goes wrong (I have a camera attached to the printer).

To answer both of your response, my setup is different.

I do my CAD and slicing in my house/office. It's nice and warm there and has it's WiFi router.
The printer is in the shop. It's kind of cold there. It has it's own WiFi router.

To set up the Rpi I had it, and the touch screen, in my office where I spent a few hours setting it up. When I slice, in the office, I put the g-code file on a sd card and go to the shop to turn on the printer and set it up with filament and while I'm there I put the sd card in. Easy Peasy. I just got tired of the archaic Graphic LCD and having a laptop connected to the printer to make control easier and faster.

I should have known that trying anything with a RPi is anything but easy or simple. :smile:

I did it and it didn't work. It still displays the 8.3 format.

I had also uncommented the option below it, the option to scroll long file names on the sd card. I don't suppose that that is why it fails to show the long format, does it?

Had you restarted OctoPrint since flashing the firmware with the new changes? OctoPrint will detect the settings on initial connection I think, but I tend to always restart with major changes.

Are the two WiFi routers on the same local area network (i.e. can devices on one communicate with the other)?

I understand the setup in the shop and the addition of a touch screen to make (local) control of the printer easier and faster. If it were me, I'd take the next step and eliminate transferring g-code files via the SD card.

If you describe your network topology, we might be able to suggest ways to make this work.

I'm very happy with my RPi / OctoPrint setup and I think it is easy and simple :wink: :innocent:

Yes, I did.


Do you have a PC that controls it through a web browser? Or is it stand alone with a small touch screen?

My setup is a headless RPi 3B connected via WiFi to the same local area network as my desktop. I have a cell phone and a tablet (two actually) connected as well. I connect to OctoPrint (and control the printer) with Chrome or Firefox on my desktop and the Printoid application on one tablet, Printoid-Lite on my cell phone. I can also use browsers on both tablets and the phone.

I experimented with Octodash on a 7" touchscreen connected to an RPi 3B+ but it currently isn't connected to a printer. I didn't have any problems with it but returned to my current configuration that I've had for a couple of years.

I don't have room for a laptop or a monitor / keyboard next to the printer so the (Android) tablet is my up close and personal connection to the printer. I use a 3D printed stand for the tablet.

Most WiFi routers can be converted to WiFi access points by moving cables and couple of small configuration changes. You can have multiple access points in a single local area network. Perhaps we can help you configure your network(s) so they can communicate with each other.

If I read it correctly you are using a web browser on your tablet to control OctoPrint, is that correct?

I primarily use Printoid (an ~8$ Android app) on my tablet to control OctoPrint.

I looked into this after you've mentioned it. Except for one app, AstroPrint, they all (I think three in total) rely on OctoPrint and that's kind of not making sense to me.

The way I see it that I will have a computer (Mega 2560) being controlled by a second computer (RPi) that in turn is being controlled by a third computer (Android Tablet). I want to take one of them out of the equation.

BTW, the 7" touch screen is not a 'computer' in this case. You can't load apps to it, as far as I know/understand.

I'm back from the long weekend and I will look into the problems with my setup and get back here and post observations.

But its the usual way with the OctoPrint web GUI too:

Printer -> RasPi -> PC with browser connected to OctoPrint.

You are correct and that's exactly how I don't want it to be. I was hoping to have only the 3d printer and the RPi and a small screen to make everything compact.

Then you may have a look on this: