Over-Current Change when Attempting to Connect to Printer

What is the problem?
I just got Octoprint up and running but cannot connect to the printer via the Pi. Running dmesg states there is "over-current change"

What did you already try to solve it?
I started with the initial troubleshooting and attempted to narrow in on the problem.

Firstly the Pi is functioning well. It is connected to the internet, and works as I would expect it. I also attached a webcam which displays its image properly which further suggests the Pi is not at fault.

I was going through the troubleshooting guide and ran the dmesg command to see if the main-board (Skr v1.4) was recognized by the Pi. There was only the "Auto" option shown in the Pi and the dmesg showed that the ports had "Over-current change."

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

Octopi Version: 0.17.0
Pi Version: Raspberry Pi 4B (2 GB)
Printer: Ender 3 Pro
Firmware: Marlin bug-fix 2.0
Mainboard: Skr v1.4

A few months ago I was able to control the printer via pronterface. I then made some upgrades and when I tired to connect via pronterface again for some troubleshooting, Windows displayed a "Power Surge on USB Port" error and I could not connect. I did the troubleshooting without pronterface and ignored the problem.

My guess would be something on the board is damaged. When trying to connect via pronterface, I tried different cables and different ports on my laptop, none of which made a difference. If the same problem is happening here, I can only assume the board is damaged (if so it's on to mainboard number 3 :upside_down_face:).

Update 1: Forgot to include the output from dmesg, snippet of which is now below:

[ 3135.095118] usb usb2-port4: over-current change #3244
[ 3135.215526] usb 1-1-port2: over-current change #3240
[ 3135.335169] usb usb2-port1: over-current change #3245
[ 3135.455620] usb 1-1-port3: over-current change #3243
[ 3135.585135] usb usb2-port2: over-current change #3245
[ 3135.705528] usb 1-1-port4: over-current change #3249
[ 3135.825042] usb usb2-port3: over-current change #3245
[ 3135.945484] usb 1-1-port1: over-current change #3246
[ 3136.065053] usb usb2-port4: over-current change #3245
[ 3136.185251] usb 1-1-port2: over-current change #3241
[ 3136.305054] usb usb2-port1: over-current change #3246
[ 3136.425586] usb 1-1-port3: over-current change #3244
[ 3136.545127] usb usb2-port2: over-current change #3246
[ 3136.665619] usb 1-1-port4: over-current change #3250
[ 3136.785181] usb usb2-port3: over-current change #3246
[ 3136.905579] usb 1-1-port1: over-current change #3247
[ 3137.025149] usb usb2-port4: over-current change #3246
[ 3137.145537] usb 1-1-port2: over-current change #3242
[ 3137.265269] usb usb2-port1: over-current change #3247
[ 3137.385643] usb 1-1-port3: over-current change #3245
[ 3137.505161] usb usb2-port2: over-current change #3247
[ 3137.625594] usb 1-1-port4: over-current change #3251
[ 3137.745175] usb usb2-port3: over-current change #3247
[ 3137.865631] usb 1-1-port1: over-current change #3248

did you set this jumper to VDD?


Yeah those pins were jumped to VDD properly. I also replaced the jumper to make sure it wasn't a problem with that; still no luck.

Maybe there is a bend pin in the usb port of the skr

Unfortunately not, everything looks as it should.

then you're probably right.. something is wrong with the board

you could test this


maybe it helps

If the tape tricks doesn't work...

If it were me I'd consider creating a small M-F USB Type-A adapter. Three of the four lines would just pass through. The 5V line would include a diode perhaps. You'd want to block power coming in the toward-the-Pi direction, presumably.

Gave the tape trick a shot, unfortunately it didn't work either. I ordered a new board and hopefully that works without a problem, but if it is unable to connect to that one too, this will be a bigger problem.

Hmmm this is an interesting idea. I think the problem is the board wants to take power from the Pi. The tape trick ideally ruled that problem out, but trying a diode inline with the 5V line might be worth a shot if a new board doesn't work.

@OutsourcedGuru
wouldn't you want to stop power from going into the printer, rather than into the pi?

Sorry if I got the direction wrong but I thought the over-surge was on the printer side. Same advice then, just turn the diode around.

And yet, here's one of my other projects.

To close the loop for future reference, in a not that helpful manor, buying a new board fixed the problem.