Preheat temperature set to 415 celcius

I recently switched my Raspberry from an Anet to a Prusa.
Removed all related settings and placed the Prusa ones in. Everything works like a charm except..
At night (when not printing) I often remove the power from my Raspberry. The first time after startup when I start a print my nozzle temp is set to 415 celcius. Manually lowering it has no effect. Then it keeps heating up till 320~ and I receive a firmware error and octo disconnects from the printer.
Few seconds later I can connect to it again and when i hit print again it just preheats like the correct g-code says. This happens only after a power loss in the Pi. If my print finishes and 2 days later (without cutting the power) it goes to the g-code temperature also.
What could this issue be?
Log files.

That sounds odd. Marlin has a max temperature protection, by default this is usually around 280c, I can’t imagine that prusa would change this and ship to allow 450c (the aluminium hotend block on an e3d melts at 350c). Have you changed the firmware. On my octoprint if I hit preheat to 450 it will just set it to 275.

Also when you say preheat, do you mean the preheat that happens when you click ‘print’, preheat via the printer console, or the octoprint plugin that gives you a preheat button?

Is this a particular print or all prints? Have you check the gcode that there isn’t something that has the 450 number in it and some sort of corruption is happening. What temperature does the print say it is at when preheating, assuming it doesn’t get to 450 or you would be buying a new hotend block.

It is on all prints. I checked a bit. Prusa has a limit of 305 celcius which sounds about right.
However when Octopi sets it to 415 it goes into shutdown after reaching 300+ (so guess its firmware protection) then after the reset it works normally again.

When I mean preheat it is the preheat button plugin. I had to install it in as recommended for the filament manager plugin. Don't actually use the plugin. I always just start my prints by hitting load and print.

There was no need to remove the printer profile for the Anet. Just setup a new profile.

That is no good. You can destroy the file structure on the SD card.
Can you also share the serial.log.

Well I could but that would be useless I see.

2020-07-03 09:03:33,713 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

I have now enabled it. When I'am home i will power off the Pi completely to recreate this error again.

In Lieu or logs. So just to confirm.

After a power on of octoprint (what about reboot?) the first job only will preheat to Mad temp, Printer safety will halt printer, clear error, reconnect octoprint, every job afterwards is fine.

What if you run the first job off an SDCard directly on printer? Just to rule out printer oddity.

And octoprint was working, all you changed was the profile for new printer? Nothing in the gcode section of octoprint preferences?

Also if you do use the preheat plugin button does that have same effect? What if you manually set preheat temp after power on?

If i print directly from the sd card it is all working fine yes. After a Octopi reboot I'm not sure I haven't tested it.
The only changed I made when i went to Prusa is that I switched from the Cura slicer to the Prusa slic3r.
So the G-code definitely changed in that matter.

First few prints I used the SD-card only and that worked flawless. However after hooking up the Octoprint the only problem I had was the heathing. After that issue I removed the Anet profile and installed a new profile (I thought it might be because of that)

I will do some testing regarding setting the temp manually after a power cut and using the pre heat button and will share the results / logs later.

So I restarted the Pi and printing issue didn't occur.
After powering off completely I noticed the pre-heat button was greyed out. So I couldn't test it.

Once I started my print it set the nozzle temp to 415 and started to push that heat.
Bed went to 60. I manually was able to set the bed to 50-60-40 or whatever i wanted.
But the hotend.. I couldn't lower nor higher it. Disabling it didn't work also.
After 300+ my printer gave the notification that max temp has reached and securely shut itself down.
After cooling off to 250 it was able to connect again to Octopi.

After that I did the exact same thing, hit print. And the temp went to 215 like it should've in the first place..

Got both log files :slight_smile:


Can you share the start sequence of the gcode file?

Sure thats slicers default

M862.3 P "[printer_model]" ; printer model check
M862.1 P[nozzle_diameter] ; nozzle diameter check
M115 U3.9.0 ; tell printer latest fw version
G90 ; use absolute coordinates
M83 ; extruder relative mode
M104 S[first_layer_temperature] ; set extruder temp
M140 S[first_layer_bed_temperature] ; set bed temp
M190 S[first_layer_bed_temperature] ; wait for bed temp
M109 S[first_layer_temperature] ; wait for extruder temp
G28 W ; home all without mesh bed level
G80 ; mesh bed leveling
G1 Y-3.0 F1000.0 ; go outside print area
G92 E0.0
G1 X60.0 E9.0 F1000.0 ; intro line
G1 X100.0 E12.5 F1000.0 ; intro line
G92 E0.0
M221 S{if layer_height<0.075}100{else}95{endif}

Is that the start code in the slicer or is that the actual code that you want to print?

that is the actual printer g-code starter

What did you say, what slicer you are using?
This placeholder (like [first_layer_bed_temperature] ) are the culprit. They have to be real numbers.
You may check the manual of your slicer for the correct names you have to fill into the start code section of your slicer.

I'am using PrusaSlicer 2.2.0 with default Mk3s settings haven't changed anything myself.
Seems kinda odd if there would be a flaw in the gcode, wouldn't it happen then every time you are trying to start a print?

So the what you shared is the Start G-code in PrusaSlicer?.

How does the code look that you write onto the SD card?

If you mean what my start gcode is regarding octoprint its empty.
Besides that I never changed anything in any Gcode. From my slicer it is on default as how it comes when you install it.

The only thing in Octorpint I have regarding Gcode is when a print is cancelled

; disable motors

;disable all heaters
{% snippet 'disable_hotends' %}
{% snippet 'disable_bed' %}
;disable fan
M106 S0

If I print over SD-card I assume its the same g-code as i shared in my previous post since it is sliced over the same slicer.

I like to know the contents of the gcode file you save to the SD card that you print from.
The slicer is meant to fill in all the placeholders in the start gcode section.

Here is a complete gcode file (was too big to upload here, 4MB)

Sorry, can't access: 403 error.

i put it in mega then