Printer keeps resetting at a certain Z height every time it homes

I've had the Ender-5 for about a year and it has always worked with Octoprint!

But when I either Home from the Octroprint or start a print and it home's, the print bed reaches up about 3/4th of the way and restarts the whole printer. what is going on ? Is this a known octoprint issue?

What is the problem?

Printer keeps resetting when it reaches a certain point in Z Homing

What did you already try to solve it?

Restart printer and Pi multiple times

Have you tried running in safe mode and if so did it solve the issue?

Yes, no same issue still

Complete Logs

octoprint.log (21.5 KB)

Additional information about your setup

If I go to the printer and Home XYZ from the printer it homes all the way up no problem.

Your printer is reporting it's firmware as Marlin 1.1.0. This is very old and I would not be surprised if it was part of the issue. In addition, it's probably Creality firmware which if you look to the list of printers with broken firmware, seems to be dominating.

Some homing issues were solved with either putting an SD card in/out, but that is a newer issue so unlikely to be the problem here.

Has this always been an issue? If it is new, I would look at cabling for interference. If it has always been an issue, try updating the firmware.

1 Like

Hi Charlie... very recent issue.. Just happened a week ago. I have been using Octoprint with no issues for about a year.

How do I update firmware ?

What do you mean look at cabling for interference? Sorry can you please explain what I should do.

I re-imaged Octopi and Octoprint and set up everything from scratch and still have the same issue.. Is there a way to perhaps go back to an older Octoprint version and see if that fixes the issue ?

Not every fault is the fault of OctoPrint.
Can you share a serial.log?
But please with more than just one incident.

What @Charlie_Powell means is, that if the USB cable is maybe touches a motor or gets bad contact due to the movement of the z-axes.

1 Like

serial.log (148 Bytes)

here ya go :slight_smile:

Forgot to say: you may have to enable serial logging before data is stored in that log.

How do I do that ?

Is written here: logs

Like this ?

Settings > Serial Connection > scroll to 'enable serial logging'

nvm found it... It's enabled now.. Now you want me to try and make it break a few times and then share the serial.log file ?

1 Like

That would be useful, yes.


Especially not things like a printer suddenly rebooting, ignoring endstops, not heating up, and so on and so on. That reeks of a firmware crash or mangled communication.

No downgrading, upgrading or whatever-grading of OctoPrint will be able to fix issues with your firmware or your communication reliability.

1 Like

My printer is printing fine as we speak from the SD card directly! The only time it keep rebooting is when I home it from the Octopi.local

When things work fine when printing from SD card, this does not include working fine via USB. The controller has to do quite a few things more. And if there are faults in that firmware code, things mess up.

1 Like

I understand.

Hey guys thanks for all the help so far trying to figure this out!

I have attached the Log as requested.. I Home once and it rebooted... then restart everything and it finally worked woot.. After days it finally worked.. So I restart again and Home and it rebooted again :frowning:

serial.log (8.8 KB)

New Error!