Printer stops printing at same time every day Com error

What is the problem?

Have a Ender 3 V2 pro printer and like to print for 20H. This is Day 2 of trying and on both days, at the same time de printing stops, kills all outputs, so Ender is switched OFF.
Always exact on the same time!

2023-3-17 the printer was printing for about 12 hours
2023-3-18 the printer was already for about 15 hours

What did you already try to solve it?

I had a older powersuplly and replaced is with a NEW org Raspberry powersupply, because some times I got warnings of less power. So 17-3 was with a old powersupply and 18-3 with a original NEW Raspberry Powersupply
The USB serial cable replace with another, Ferried coils on both sides of the USB. USB switch to other port.
The USB doesnt power the mainboard of the Ender printer. Its pure Serial USB connection.
This is not mij FIRST 20H or longer print session, earlier prints I didnt have any troubles printing After 0:10 AM. I update Octoprint :
|2023-03-09 16:12:38|Resource Monitor 0.3.11 :arrow_right: 0.3.12Update successful
|2023-03-09 16:12:22|OctoPrint 1.8.6 :arrow_right: 1.8.7Update successful
Running OctoPrint 1.8.7

Have you tried running in safe mode?

No i didnt because is always worked perfectly long hour printing.

Did running in safe mode solve the problem?

No idea, its a 20H run printing and cost my now already alot of filament.
I will print the model direct from SD onto the Ender SD port, because I need this model asap.
Until then I will not print AFTER 0:00 til 0:30 every night

Systeminfo Bundle (50.4 KB)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 915718144
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.8.7
systeminfo.generated: 2023-03-18T23:44:41Z
systeminfo.generator: zipapi


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
everything can be found in
octoprint-logs (6).zip (33.3 KB)
octoprint-logs (7).zip (118.6 KB)
2 printlogs of both events with a power cut because of a serial error at 0:10.......

Is the Ender just without power? All the time until you find it in the morning? Or just for a short time?
Or has someone used the power switch?
Do you have some kind of smart plug in that power line?

So, if the Printer is turned off at 00:10 in the night, you may check your mains.
Is there something that does a scheduled reset? You may test a different mains outlet.

In all, this is no OctoPrint issue.

Some hints to your setup.

You may delete Terminal Commands from your plugins. It is not compatible and does not work.

Also please avoid resetting the Pi by power cycling it. This can lead to a broken file structure on the Pi's SD card.

The Ender is shutoff the power by GPIO of the raspberry.
On my Octoprint I use GPIO relais to switch the power on/off of the Ender printer and turn on/off light. What i read the log. Because it looses the serial connection it also shutoff the GPIO relais that are actif, So Ender is shutoff on power. Never I had 230V grid issues in the house. At that moment , at 18-3-2023 I was also awake and their was also no power fallout in the grid. I use a UPS (other use then 3D printer) and the ups also didnt give a alarm of Power failer or that i hear switching of a powerrelais on my UPS because of a grid error. The GPIO is directly connected to the same main as 3 years now. Nothing els is connected on this main for the last 3 years, never got out.
On the same Main the Rapsberry powerunit is connected and I dont; see any powerlosse/startup in the rapsberry log or Ocotorpint log. I have seen, in the log, on the 18-3 I removed the power of the raspberry without closer of octoprint/Raspberry. This error I dont see at 19-3-2023 at 0:10 in the log. So the Raspberry is still running and the Ender is switched off by GPIO.
And the log is CLEAR, because it lost serial com it will switch off GPIO Ender. So the power was stil their but because of a serial comm error it shutsoff the GPIO!
Also in de log of octo print I dont see any reboot because of 230V grid error/power/crash what os ever.

I will keep in mind next time, to shutdown rapsberry and the switch the powerunit of the raspberry.

I just started a new printjob WITHOUT octoprint and when it still prints at 0:10 then I am 10000% sure its a octoprint issue.

I will look into the terminal Commands. No idea what you mean by not compatibel and does not work. But I will look onto it.

Few months ago I could print 32h jobs and now 23 hours and 59 minutes......
After last update it acts like this, and my first longer print event after update, earlier prints after update had a print time of 8 or 12hours.

I will reply to night EU time that the status is of printing at 0:10 and later......
keep up the good Octoprint work!

When the print doesnt fail to night, I will try another thing and that is, POWER the Ender mainboard by USB Rapsberry instead of its own powersupply.
Then we can see Is the serial Comm earlier gone then the power of the Ender or because of power off Ender their is no serial Comm any more.....
What I read from the logg, First the comm is gone, because of that it shutsoff the GPIO.

Keep you posted

Do you use the Enclosure plugin for this?

Then I strongly recommend to run the safe mode. Or just unplug the relay for test.

That will not work. You need the Ender PSU to power the heaters and the steppers.

Yes I do use Enclosure plugin, works fine for 3years. Just set it ones and never had troubles. Just GPIO trigger nothing else with this plugin.
By the way, what i mean is, Power the mainboard with USB from raspberry. Then You know if its a Ender powersupply or mainpower failer instead or a mainboard failer.

And I said: That will not work. USB only has 5V 500 mA. The printer needs 24V 15 A

It is pure to keep the mainboard up and running, then we can see IF its a Ender powersupply problem or the maindboard Or Octoprint because that gets power from Raspberry when the powersupply stops working.
Octopi says that is loses comm, because of that it trigger GPIO and switches off the power of the Ender. Why lose its serial Comm? Because of powerdrop of Ender powersupply Or a fail Mainboard or Octoprint or Plugin tells that serial is lost and because of that GPIO are triggerd and shutsdown the powersuplly of the Ender?
To see if its a Ender powersupply problem that kills the mainboard and also the serial connection of something else.......
When its a powersuply problem the mainboard stays running at 0:10 because its powered by USB.
When its a mainboard failer the comm will stil be lost at 0:10, then we know its a mainboard problem.

Never tried???
When you connect a original USB(with power) from raps tot USB of the Ender mainboard and you switch OFF the powersupply of the Ender the mainboard incl display stays ON because its fed by USB power of the rasp.
Because of that, I use a USB without power and only Serial Comm. Else the mainboard is 24H 365days ON incl display instead raspberry only On.

No, I have no Ender...

What we are talking about is backpowering - and that comes with issues:

Didnt know but I already cleared that with a USB without 5v power Data only.

What mainboard is in the printer - stock OEM or a BTT SKR or similar and with what firmware version?. Always shut down the Pi from the Octoprint GUI - pulling the power is certain to corrupt the microSD card, eventually. At least you are not powering the mainboard through the USB port, in some older printers, backpowering has blown the USB ports on the Pi.

What size is the microSD card and have you checked the free space on the card? You can do this by ssh'ing onto the Pi and typing df. Disable anything to do with the webcam and timelapse - if there's a problem with free space on the microSD card, filling the card up will cause a system hang, only fixable with a reboot, but if its diskspace you need to find the cause. Nothing smaller than 8Gig, ideally 16. Run a backup on Octoprint and download it.
Pull the card with the Pi off and reinstall Octoprint image using RPi Imager - if the card has bad blocks it may never reinstall.

Do you have a UPS running the printer and Pi power? Electrical noise through the power feed WILL cause problems with the SMPS in the printer, and this gets to the mainboard, which can restart, or hang, which drops the USB connection to the Pi.

Due a filament error the printing of yesterday is killed this morning. Restarted an new print. The printer was stil working at at 8:45 this morning, so powersupply, grid error or mainboard error I can say NOT the course of shutdown. has to be Octoprint or Plugin
Creality 3D silent mainboard v4.2.7
I dont power de mainboard through the USB, it can be done for testing. The risk is for myselfs
SD is 128Gb, freespace = 81Gb
Timelaps is not used
I wil buy a new SD card and install latest clean version of Octoprint
The I am sure that this weird problem is hopefully solved

UPS is NOT connected to the printer,
My intention was to INSTALL a UPS on the printer but when you tell me about SMPS.
i will NOT install a UPS onto te powergrid of the printer.

That's the question for the safe mode.

1 Like

You should put a UPS on your printer, from my experience the Creality power supplies do not give enough isolation from noise or power brown-outs.

A 550W UPS which will provide isolation and protection from brown-outs - this will power two Ender 3's or one CR10S, you can use NUT [networked UPS monitoring] and the UPS plug-in for Octoprint to monitor the UPS.

Failed prints have cost you more in filament than a 550W UPS - plus all the time you've lost, so they are worthwhile for anybody doing prints lasting 24 hours or more. I have one print job that takes nearly 60 hours.

After another shutdown at 0:10 I reinstalled Octoprint incl plugins.
Config the plugins same as it was.
Troubles gone

ticket can beclosed, No idea whats going on but iets fine for me thats it works now

1 Like

It seems that you solved your problem but if it happens again then this might help you:

On old freezer or other equipment can send power spikes that breaks the USB connection for a short time and Octoprint will then disconnect. Ferrules only work for certain frequency range so they may not filter out these types of spikes. Your UPS is probably fine anyway so it will not have a problem with this.
An 8.5 m long extension cord was enough to dampening the spiks for me. What also worked was to move the printer to another room. Make sure that both the printer PSU and the octoprint PSU is on a long extension cord (can be the same extension cord).

This “thing” can make do with a much shorter cable since it works as a coil.

I hope it stay fixed with your reinstall of Octoprint.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.