Problem setting up octoprint - print is all messed up

What is the problem?

To be honest, I don't even know what the problem is so I haven't been able to google anything, but basically, the same gcode printed from my sd card and from octoprint is messing up, here is an image of the issue.

From what I noticed, the first layer prints fine but after that, it just goes rogue, and if I keep waiting for it even try to print off of the bed and the motors won't stop even ignoring the limit switch.

When checking the GCode Viewer it shows everything correct, layer after layer.

What did you already try to solve it?

I have tried reinstalling octopi, setting up a new printer, searching resources online on how to set up my Mingda Rock 3 Pro. The thing is, the same gcode works fine if I try to print from my sd card without octoprint.

Tried to use the gcode scripts that I use on Cura, also tried without it.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

N/A

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20220112230147.zip (61.9 KB)

Additional information about your setup

Printer: Mingda Rock 3 Pro
Firmware: 2.8.2
Octoprint Version 1.7.2
OctoPi Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.4

Printer profile on Octoprint
Form factor: Rectangular
Origin: Lower left
Heated bed
Width: 320mm
Depth: 320mm
Height: 400mm

Axes
X: 6000 mm/min
Y: 6000 mm/min
Z: 200 mm/min
E: 300 mm/min

Nozzle
0.4mm

Then please try running in safe mode. Also enable your serial.log (<- click this link for details), reproduce the issue, then upload a new system info bundle.

This post can now be closed, I think something went wrong during the firmware installation, it further developed even more issues but after flashing it to a different version and then going back to the BLTouch version it worked.

Also, the mingda support mentioned that when setting up the printer the Axes needs to have those values: X,Y: 79.25, Z,E: 400

Thanks