Problem updating Octoprint from 1.3.12 to 1.4.0

What is the problem?

Trying to update from the Octoprint GUI but I'm getting an error, I think to do with my python version

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

From the plugin_pluginmanager_console.log

2023-11-12 16:56:28,919 /home/pi/oprint/bin/python2 -m pip --disable-pip-version-check install --no-cache-dir
2023-11-12 16:56:31,313 > Looking in indexes: Simple index, piwheels - Simple index
2023-11-12 16:56:31,314 > Collecting
2023-11-12 16:56:32,316 > Downloading
2023-11-12 16:56:33,319 ! ERROR: Package 'OctoPrint-TranslateModel' requires a different Python: 2.7.16 not in '>=3,<4'
2023-11-12 17:27:10,727 /home/pi/oprint/bin/python2 -m pip --disable-pip-version-check install --no-cache-dir
2023-11-12 17:27:13,125 > Looking in indexes: Simple index, piwheels - Simple index
2023-11-12 17:27:13,125 > Collecting
2023-11-12 17:27:14,128 > Downloading
2023-11-12 17:27:15,131 ! ERROR: Package 'OctoPrint-TranslateModel' requires a different Python: 2.7.16 not in '>=3,<4'

From the octoprint.log

2023-11-12 18:22:43,583 - octoprint.plugins.softwareupdate - ERROR - Update of octoprint can not be performed, please also check plugin_softwareupdate_console.log for possible causes of this
Traceback (most recent call last):
File "/home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/", line 987, in _perform_update
update_result = updater.perform_update(target, populated_check, target_version, log_cb=self._log, online=online)
File "/home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/updaters/", line 116, in perform_update
raise exceptions.UpdateError("Error while executing pip install", (stdout, stderr))
2023-11-12 18:22:55,054 - octoprint.server.heartbeat - INFO - Server heartbeat <3


Please always attach complete logs, not snippets.
Preferably attach the systeminfo bundle.

This is your issue. You still run OctoPrint on Python 2,7,16. OctoPrint 1.4.0 requires Python 3.

What's the correct way to upgrade to python 3 from the installation I have already?

It's written in the Blog link I posted.

Or you make a backup of your settings with the OctoPrint Backup feature and start all over with a new OctoPi/OctoPrint install.

I followed what it said in the blog (I had done this previously before coming to forum for help), but I did it again anyhow with the same result on Step 2.

pi@octopi:~ curl -L --output upgrade. py % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 154 100 154 0 0 1149 0 --:--:-- --:--:-- --:--:-- 1140 100 27973 100 27973 0 0 80151 0 --:--:-- --:--:-- --:--:-- 80151 pi@octopi:~ python3
OctoPrint Upgrade to Py 3 (v2.2.2)

This script will move your existing OctoPrint configuration from Python 2 to Pyt hon 3
This script requires an internet connection and it will disrupt any ongoing prin t jobs.

It will install the latest version of OctoPrint and all plugins.
No configuration or other files will be overwritten

Press [enter] to continue or ctrl-c to quit

Checking system info...
Detected OctoPi version 0.17.0
Found version: Python 2.7.16
Checking OctoPrint version...
OctoPrint version: 1.3.12
Please upgrade to an OctoPrint version >= 1.4.0 for Python 3 compatibility
pi@octopi:~ $

/home/pi/oprint/bin/pip install octoprint==1.4.0 should do that bit and then maybe the update script will be happy to get you to python3. Honestly, I would just create a backup, download backup, reflash the SD card with the latest version and restore the backup during the initial setup wizard of OctoPrint.

Thankyou everyone, I was able to do it using your help and some additional steps

Step 1: sudo apt-get install python-pip

Step 2: /home/pi/oprint/bin/pip install octoprint==1.4.0

Step 3: curl -L --output

Step 4: python3

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.